Custom DDNS entry fails with ? symbol in URL


#1

I am interested to know what I have to do to get it to accept a URL with a ? in it.
dyn.dns.he.net/nic/update?hostname=myhostname.com
If I enter the url without the “?” it will accept it. With the “?” it wont allow me to save due to “Invalid URL”

Ideas?

Thanks.


#2

?hostname=myhostname.com shouldn’t be there. Please put the hostname under the Hosts field.


#3

Hello, I tried that and it sends the NAT’d IP from Verizon and not the Public IP. I tried the autodetect button and regardless of the setting it gets the NAT’d IP.


#4

By default, if cellular WAN is running/connected using public IP address, the IP address shouldn’t being NAT’d by service provider. Can you please further confirm Public IP for the cellular WAN is NAT’d by Verizon ?


#5

@sitloongs Not sure if your understanding me. I get a 100.x.x.x IP on the Pepwave from Verizon. It is not a public IP as the 100.x block is a carrier block that is NAT’d. The real IP I get when I do an IP lookup is a Verizon public

Having DDNS updating to a inaccessible private IP is worthless. My goal is to authorize the public IP that I am on to temporarily access management systems when I am mobile. So updating DDNS with the Public IP would be helpful.


#6

@Joshua_Pool

A bit confuse here, you need to get the public NAT’ed IP from Verizon and you need to access the device using the Public NAT’d IP ?

May i know you have the inbound port forwarding/NAT Mapping defined at the service provider level ? Else you should not able to access the device. Can you further confirm ?


#7

@sitloongs I only allow authorized IP address access to VPN servers. So what if I wanted to have the Peplink update my DDNS “roaming.mydomain.com” with the public IP. Then my firewall is set to allow the dynamic “roaming.mydomain.com” access the VPN server. I do all of this currently with Mikrotik with no issue.


#8

@sitloongs If you allowed normal syntax in the custom DDNS fields this would work. he.net DDNS has an autodetect IP feature that will set the hostname to the public IP you are connecting from.

Autodetect my IPv4 address:
http://dyn.example.com:password@dyn.dns.he.net/nic/update?hostname=dyn.example.com"


#9

Now i get what you want, Basically Public NAT’d IP address will be auto detected if WAN interface is running using private IP address.

Seem Verizon is using a reserved IP, hence you need to enable the detection using the hidden feature.

For more information, please refer to the attached screenshot.

Please try that and let us know whether that meet your requirement.