Creating a static route

#1

Good day guys.

Trying to understand the basics with the peplink

I have 2x Balance 20’s
Lets call one Bal10 and other Bal70

Bal10 dhcp is 192.168.10.0 network
Bal70 dhcp is 192.168.70.0 network

  1. Bal10 Has cellular on Wan1
    Bal10 Lan1 -> Bal70 Wan2

  2. Bal70 has Wan2 setup as DHCP

Just the basics here Computers on Bal10 can ping everything on itself and Bal70.
However computer on Bal70 can not ping computer on Bal10

Question:
How do I setup the static routes need for this. Or am I missing a basic option.

THanks

0 Likes

#2

Hi @thfraley,

I would probably use the Outbound Policy setting - something like this:-

Hope this helps,

Steve

1 Like

#3

Bal70 is doing a NAT to 192.168.10.X on the WAN so BAL10 does not see the 192.168.70.0 network.

1 Like

#4

You Set up Static Routes in Network | LAN -> Network Settings.

You also need to change the WAN on the Bal70 to IP Forwarding instead of NAT as Ron says in Network -> WAN | Connection Settings | Routing Mode. Click on the little blue icon and then the link to enable IP forwarding:

image

Your set up will look like this:

image
(assumptions made about WAN/LAN Ip addressing for examples sake)

6 Likes

#5

Thanks, guys,

You hit the nail on the head… I was not aware of the IP addressing option another hidden link lol.

I’ve got things to work enabling that and a static route in the networking settings.

Question what would the benefit of using outbound policy? Would you use that in replace of the static route option?

0 Likes

#6

Glad you got it working.

No benefit in this specific case as the issue was the NAT on the WAN of the second Balance 20.

2 Likes

#7

@MartinLangmaid,

So if I was to leave it as NAT then I would use outbound policy and would get same results?

0 Likes

#8

No. NAT on the second balance 20 (BAL70) was blocking inbound connections. Outbound policies control outbound routing via the WANs - so in a mult-wan setup outbound policies set how traffic should flow across the WANs.

You needed to control routing on the LAN - which you did with a static route, then on BAL70 you needed to allow inbound traffic on the WAN (by default blocked by NAT for obvious reasons) - which you did by enabling IP Forwarding rather than NAT.

4 Likes

#9

I have the same setup, using a Balance 210 in place of Bal10 and a Pepwave SOHO in place of Bal70. Does IP forwarding and static routing need to be setup on SOHO? Or does the static route come from the 210?

0 Likes

#10

Static route on the B210, IP forwarding on the SOHO.

1 Like

#11

Thank’s for the response.

I must be missing something then as I still cannot access any lan devices on the SOHO from the 210 subnet.

Have static routing set on the 210. Destination Network: 192.168.125.0/24 Gateway: 192.168.206.2

Rosalia%20Seed

0 Likes

#12

that looks right to me. Assume your firewll rules on the SOHO are all any:any allow? If not explicitly add the 192.168.206.0/24 inbound as allowed.

Can you ping from the soho lan to the b210 lan? Whta happens if you try and ping a lan device on the soho from the ping tool on the web gui of the balance 210?

1 Like

#13

All firewall rules on the SOHO for inbound are set to any:any allow. Have added the exception, still no luck.

Cannot ping any device from the 210 to the SOHO lan, however, I can ping the LAN IP of the SOHO from the 210: 192.168.125.1.

Can ping multiple devices going from the SOHO to the 210 lan.

0 Likes

#14

OK so that’s interesting. Static route is working.

What default gateway is set on the LAN devices on the SOHO? Any chance they are not using 192.168.125.1 as their default gateway?

1 Like

#15

All devices on the SOHO lan were statically set to that gateway of 192.168.125.1, with the exception of a workstation that gets its IP from DHCP.

0 Likes

#16

Weird. OK/.
So can a device on the LAN of the SOHO ping the LAN IP of the B210 specifically? Any chance the devices on the LAN of the B210 aren’t using it as their default gateway?

So far we have proven that the static route is in and working (as the B210 can ping the LAN IP of the SOHO).

1 Like

#17

The workstation on the lan of the SOHO can ping the lan IP of the B210. The devices on the lan of the B210 are using the gateway of 192.168.206.1.

0 Likes

#18

For the sake of sanity screengrab the WAN port settings/config on the SOHO. Wondering f that is actually still in NAT mode.

Re reading this thread now. Can you ping from B210 Web Gui to LAN of SOHO?

1 Like

#19

Am getting a good ping response going from the web gui of the B210 to the lan IP of the SOHO.
Can’t reach the locoM2 at 192.168.125.151 or any other device on that lan. Plus those devices on the SOHO lan lose internet access.

0 Likes

#20

Still no luck, worked on it over the weekend. Am still not able to ping any devices going from the SOHO to the Balance 210 and vice-versa. Can’t see what else I could be missing.

Also noticing, that even with IP Forwarding disabled on the SOHO, am still able to ping the LAN IP of the SOHO at 192.168.125.1 from the Balance 210.

0 Likes