Converting Verizon Jetpack 8800 thru USB to Peplink products NEED HELP!

I currently have two Verizon Jetpack 8800 devices in my home due to no high speed ISP in the area.

One of the Jetpacks is connected to a Balance One and the other a Surf SOHO.

I am connecting the Jetpacks to the Peplink products via USB so I can access the Cat5 for my wired devices. The problem is connecting the Peplink devices via USB cuts the bandwidth in half compared to what it broadcasts wirelessly.

I have worked with Peplink technical support for over a year, maybe closer to 2 years and they have no idea. Both Jetbacks react the same way so pretty sure it isn’t a bad Jetpack. It sounds like their support team is in a different country and doesn’t have access to the Verizon Jetpacks.

Anyway, I am looking for a solution to take advantage of the Verizon Unlimited plan I have with the Jetpacks but get it into my home network without dropping off all the speed.

If there is another way to do this I am all ears! Would really appreciate hearing from someone out there that might have already conquered this issue or knows of a different solution.

Thanks in advance,



I’m the the one who handling your ticket. From your device throughput test and comparing with Peplink lab device in USA, we can confirmed that the issue is not related to the SOHO USB WAN. Beside that, you also confirmed that that the same issue when connected to another Balance One device. So base on the conclusion, it should be something actually limiting the bandwidth.

Recently we heard some feedback from USA partner that Verizon may having some sort of bandwidth throttling base on the TTL value. Do you think you can help further test the “Enforced TTL” feature that just introduced in firmware 8.0.1 ?

Reference for TTL value influences:


How about employing a “made for the purpose” device such as a Max series router? – LTEA inside of a capable router – all in one box. I must say, although such arrangements as you describe often do work quite well sometimes the best solution is a “non-kludgy” one. :grinning:

1 Like

I would love to move to a Max, let me know when Peplink puts a Cat18 modem in one similar to the 8800 :grinning:

I already have the SOHO and works great with my AC791L over USB, I can upgrade to the CAT18 8800 for $99 with a contract or I can spend much more to go to a CAT-6 max router with non upgradeable modem. I would have no problem spending more to get a well integrated device but its not an easy decision when the modem hardware is so far behind and not modular like some of Peplink competitors.

Right. I can only say what’s worked for us, our clients and our customers. Nailed-up reliability is our main priority and Cat18 modems, well, we won’t need 'em for quite some time. Quite some time. Hence our bias toward highly reliable “single box solutions.” But YMMV and it’s a wide playing field and competition is a great thing! :smiley:

1 Like


I am interested in any solution that won’t break the bank and will allow me to still maintain the unlimited Verizon 4G LTE data plan I am on. When I talked to Peplink sales about what I was trying to do (over a year ago) they didn’t mention the Max series router as an option. I’m not an IT person so a lot of the specs are a bit foreign to me so I really don’t know what I can and can’t combine to achieve results.

If you have put together a system like mine using hardware that works I am very interested in hearing what the configuration is!


I agree I want reliable first, speed second, but Cat-6 I mean its time to move on. Cat-18 will get better throughput than Cat-6 in the same conditions typically, its not that your are going to get gigabit throughput Its that you will get 40Mbps instead of 4Mpbs like in the other thread with the Max Mini compared to a modern iPad.

The main Peplink competitor has had Cat-18 modems for over a year now and they where on Cat-9 modems for a couple years before that and as far as I know similar reliability targeted at public safety.


I am still not sure I understand the logic in their conclusion. Two (2) separate Jetpack 8800L’s on two different Peplink devices (Balance One and Surf SOHO) put together in every combination possible (most recent firmware at that time) with numerous new USB cables tested to ensure that wasn’t the issue and the Engineering team when remotely logged in and saw/acknowledged the speed issue. To boot the issue is only on the download side of things. Last night I did a speed test and I was at 9.4mb down and 46mb up. Connected wirelessly to the Jetpack I am 56mb down and 45mb up… But there is no problem with the Peplink devices (Balance One or Surf SOHO) working correctly with either of the two Jetpacks… I don’t get it…

Regardless, I did try to install the latest firmware on the Balance One and after doing so it refused to communicate with the Jetpack (at Dashboard it just constantly said connecting). I had to revert back to the 7.2.1 (i think that is the name) firmware to get it working again.

I did have all the previous settings written down so I ensured everything was the same on the new firmware as the old firmware. I did note that normally the Jetpack will acknowledge a USB device when plugged in. Under the new firmware the Jetpack didn’t see the Balance One as being plugged in via USB (yes I rebooted the Jetpack and the Balance One). When I reverted to the old firmware the Jetpack was able to see the Balance One again.

Maybe some of the new settings were causing a communication issue with the USB??

Open for suggestions…


Try adjusting the MTU. We use the AC791L from Verizon, it’s tethered to a Surf soho MK3. I had to adjust theMTU to get optimal up and down.
And please understand this, UNLIMITED is a marketing word.
When you hit the limit of your data (in our case 15 gb) you will be throttled, PERIOD!

I will look into how to change the MTU (not currently familiar with the setting or term). I am aware that it isn’t “unlimited” per say but I have to say it is pretty darn close. We have 3 PS4 connected to one Jetpack 8800L and have repeatedly downloaded 40+ gig games on all 3 systems within a 2.5 day period and have not been affected for streaming or other activities. That’s 120 gigs and I don’t see any slowdown so to me that’s “unlimited”. My biggest issue is it takes 2.5 days to download that because my download speed is below 10mb when at the same time my upload is 40+mb.

Maybe I am approaching this wrong and just need to get a powered hub (USB-C to Cat5) and remove the Peplink devices from the equation. I thought Peplink would be the best solution for what I wa wanting to do but I’ve got a lot of money in Peplink devices and they aren’t delivering… It’s frustrating after a year and not having a solution available.

Look at my profile pic. That’s the AC791L near our cell signal booster. A 12 foot usb cable tethers it to The Soho. The AC791L is the second modem from Verizon tethered to the Soho in 5 years with very little problems. Any problems that we have had is because of me or Verizon. I will always use Peplink. Here are some pics. Of MTU settings. Start at 1500 and go down from there in increments of ten and speed test and take notes as you do this.
As far as Unlimited goes, what is your data cap at? 20 gb, 30,gb, 40, 60. Max it out and then test your speed. There is always a cap, if you reach that cap, you will have slower speeds.

First pic. Show WAN connections. The one on standby (priority 2) is the AC791L it’s data cap has been maxed and is slow up and down. The connected (priority 1) is my iPhone. It’s connected to the Soho by WiFi to the phone hotspot. We are using it because the phone data cap hasn’t been reached yet.
Go to connection details to see MTU settings. (Second pic.)image


I will definitely be doing this when I get home and I will post updates… By adjusting the MTU you’re thinking I will be able to get the download rate from below 10mb to above 40mb where the upload speed is correct? I figured packet size would be universal to the download and upload rates.

As far as the Unlimited plan, I think I’m grandfathered in on their unlimited plan that came out last year. I remember they told me I might see a speed drop if the tower is congested but since I live in the country, I am guessing that’s why I haven’t seen a drop. I have pulled 100’s of gigs down in a month’s time with no speed reduction (below what it already is).

Below is a reference link:

Thanks for the help.

This is the speeds that we get for the SOHO device (via USA office test lab) using the Jetpack 8800:

This actually isolate the issue for the SOHO device performance issue. This is the reason why we conclude that something may actually limited the speeds instead if the SOHO/Balance Device.

Do you tested the 8.0.1 firmware ? Still having the Jepack connection issue (not the performance) ? USB modem connection is always not easy to conclude as USB modem it self can have different HW revision & firmware version as well. This is the reason, most of our expert partner here are proposing " MAX series". I still remember in the ticket, i been requested to test the performance using other USB modem, do you have chance to test that ? This will help to isolate whether Jetpack or carrier throttling issue.

1 Like


I just returned home and switched to the new firmware but get the same problem of not connecting to the Jetpacks. The Jetpacks are on their most current firmware version. I don’t understand what is causing the issue.

I don’t have access to another modem only the two different Jetpacks. If I went to the MAX series product, would I be able to combine both sim cards so that I can have more bandwidth so that I can feed my entire house instead of having to have two separate networks?

I did just notice under routing mode for mobile internet it “doesn’t” say anything where under 7.2.1 firmware it says NAT.

I tried making the changes and was able to gain .5mb in my download.


I was able to get 8.0.1 to flash into the Balance One finally. For whatever reason I had to install it 3 times. it dawned on me I was not able to see the Enforced TTL setting so I kept installing it till it took. Now the Balance Core can see the Jetpack 8800L.

I still am not seeing an improvement in speed but i haven’t adjusted any of the new features this firmware has. Is there a value that I should add to the “Enforce TTL” field or any other fields?



Please enable RA for the device and allow Engineering team to check on that. Assume the same device for ticket 9070031.

The NAT mode should not cause anything for the USB connection.

I have sent you the message via ticket,

1 Like

Please try Enforced TTL : 65

1 Like