"Connection timeout" on Remote User Access with OpenVPN

Hello, I apologize for the grammar, I use google translate.
I bought a Balance 20X to connect on the internet a site where there is no VDSL connectivity yet, I inserted a Vodafone (IT) sim. LTE connectivity works great, but there is no way I can get “Remote User Access” to work with OpenVPN.
I’ll explain what I did. I have only configured these minimum settings, I have not changed anything else on the Balance 20X:

  • I have configured the Balance 20X as the main gateway for the network
  • I have disabled DHCP on Untagged LAN as DHCP is a server inside the network
  • I inserted the Vodafone sim without customizing the settings (APN etc …) and it connected immediately with automatic configuration
  • I updated the Balance 20X to firmware 8.2.0 build 5141
  • I activated Remote User Access of the OpenVPN type, I entered a “test” user with an 8-character password
  • I downloaded the configuration file for the “Split tunnel” client from the Balance 20X
  • on the server there is a ddns that constantly updates the IP of the sim

On my client, I have OpenVPN Connect installed. My client works fine, because I use it with other OpenVPN servers, I also use it to connect to another Balance 20 (not X) and it works great.

On this Balance 20X however, I try to connect on DDNS but it doesn’t work! In the logs on my client I read:

  • Server poll timeout, trying next remote entry …
  • Connection timeout

I also tried the following tests:

  • I also tried to use different protections besides UDP 1194
  • I tried with TCP 1194
  • I tried with L2TP mode with a preshared key, but I get the same “Connection timeout”
  • I tried to connect on the public ip other than on ddns
  • I tried another sim Tim (IT)
  • I tried to connect also connected to the Balance 20X network in wifi, but I get “user authentication failed”. This seems strange to me, I’m sure the test credentials are correct, I also recreated them.
  • I tried to activate DHCP on Untagged LAN

Unfortunately I don’t have another WAN to try, I don’t have the VDSL yet, in which case I could have stopped the sim (even if I tried 2, from 2 different operators).

Can you tell me if I did something wrong? What could I feel? Could it be a “defect” in the Balance 20X or a defect in the firmware?
Thanks a lot to everyone!