Connect a Max Transit Duo and BR1 Classic together

Hello, I have a Max Transit Duo in my RV and a BR1 Classic in a small pull-behind trailer. Both routers are setup and working however I am unable to access my trailer IP cameras that are attached to the BR1 from the Max Transit. The BR1 is ‘attached’ to the Transit using Wifi as WAN so I don’t need a cable between the two (great while traveling and when the trailer isn’t directly attached to the RV at a campsite). The Transit has a better cellular data plan, so when my kids are in the trailer, the BR1 pulls data from the Transit instead of using it’s own (lower) data plan.

I could put the BR1 into bridge mode, however it won’t act as a DHCP router for times when the trailer is left alone and the BR1 switches over to a cellular connection (so I can access my IP cameras while I’m away).

I tried FusionHub (I have a 5-license Essential pack) and meshed them all together, but FusionHub won’t connect while the BR1 is ‘attached’ to the Transit using Wifi as WAN (probably too many connection hops in the system, or you can’t have a FusionHub stacked behind another FusionHub). I even turned off encryption to see if that would help, but no luck.

Does anyone have any suggestions on gaining access to my BR1 cameras from my Max Transit?

RV: Max Transit Due using 192.168.50.1 as a DHCP server

Trailer: Max BR1 using 192.168.57.157 as a DHCP server

FusionHub: hosted on Vultr with a fixed public IP address that will only connect to the Max Transit since it can’t see the Max BR1 while it is connected to the Max Transit via Wifi as a WAN.

  1. Create a VLAN on the BR1 for the cameras
  2. Create a hidden SSID on the BR1 called camerawifi that links to that new VLAN
  3. Set a general internet access outbound policy that only uses cellular on the transit
  4. Use WIFI WAN on the transit to connect to camerawifi ssid on the BR1
1 Like

Ha, that’s a pretty creative solution, each sending WIFI to the other. The only issue is I use the Transit’s WIFI WAN connection whenever possible (such as when I park it at home, or at a campsite that has WIFI). Under this method, I’ll be using cellular all the time. Thoughts?

This can still work.

  1. Set DHCP reservation on the Transit for the wifi wan connection from the BR1.
  2. Port forward (TCP 32016 and UDP 4600) from all transit wans to the reserved IP address of the BR1
  3. On the BR1 set the VPN profile so that those ports (TCP 32016 & UDP 4600) are used instead of the defaults (TCP 32015 and UDP 4500).

Then the tunnel should build from the BR1 to the fusionhub,

1 Like

Ok, I tried my best to set this up, but it’s not working. On the Transit, I created two new port forwarding rules as follows (192.168.50.25 is the DHCP reservation on the Transit for the BR1):

image

image

I then went into InControl and used the Advanced Link Settings of the SpeedFusion Configuration, but it only allows me to select one Data Port per Link, as follows:

This link is the BR1 to FH hosted on Vultr:
image

This link is the BR1 to the Transit:
image

I wasn’t able to setup the TCP ports within FusionHub.

Why do you have that? You want a star VPN configuration. FusionHub in the middle, Tranist and BR1 as peers. BR1 and Transit shouldn’t be building a tunnel directly between each other.

If you are using InCOntrol2 for the VPN config, you have to edit the BR1 itself and set the handshake port there to the new value (32016)
image

2 Likes

This reason it’s mesh is the BR1 uses the better cellular connection of the Transit Duo and bonding. The BR1 just has a CAT6 modem and I only want to use that when I am away from the trailer. Otherwise, when my kids are using the BR1 for internet, I want it to grab data from the Transit for better data throughput and the better cellular data plans.

@ChrisMT,
Have you tried setting up “BGP” on both routers, and have the BR1 broadcast its LAN (192.168.57.157) to the DUO?

I use this method to access web admin of remote SF peers tied to a secondary Peplink device on my local network. I don’t see why it wouldn’t work exactly the same way to see cameras or other clients on your BR1 network directly at that point. You might need to make a couple of firewall adjustments to get everything working, like opening the specific port on the WAN of the BR1, but that might be about it.

-Jeff

The issue is that WIFI WAN doe snot support IP Forwarding, so inbound routing to the BR1 LAN via the WIFI WAN connection is impossible. If it was just a single LAN IP on the BR1 that needs to be accessed from the LAN of the transit then port forwarding from the WIFI WAN IP allocated to the BR1 would work.

1 Like

@MartinLangmaid, that is an issue, I didn’t think of the IP forwarding not being active on Wifi WAN when I made the suggestion. You are the guru, so you know best.

I still had tried the suggestion myself prior to your response, and I couldn’t get it working. While looking through options in Wifi-Wan I did come across this, so that’s why I figured BGP might work.

These were the results of my setup. It seems to initially connect, on both ends, but then times out.
bgp2 bgp1

Can you wire the BR1 to the WAN port of the Transit? You could then set an Outbound Policy to isolate the BR1 and have it show up as a selectable WAN connection on your Transit. This, I believe, would give you all the flexibility that you mentioned. I do this with a Bullet router and it works great - I can also connect to the Bullet directly if I choose. It will also offload the processing power required to keep the WiFi as WAN connection from your Transit WiFi radio… better throughput performance. Just a thought.

Thank you everyone for your help. I will give these options a try.

The two routers are not connected by wire, only wireless, so I don’t believe an Outbound Policy will work over WIFI.

I’m not aware of ‘BGP’ and what it can do. I did find the article below about BGP, but at the end of the report, he tells you to add static route without telling you how to set that up. I’ve never used static routes before, so using his example, I’m not sure which router gets the static route and what settings it should have:

If BGP is successful (BR1 hanging on the Transit using WIFI as WAN), I would then set my Vultr Fusion Hub server to only connect when using a cellular connection. This way the Fusion Hub won’t try to connect when using WIFI as WAN (which causes it to be sitting behind another Fusion Hub connection on the Transit).

Regarding port forwarding, does it forward (say port: 80) from all internal IP addresses to a single external IP address or can I just do port forwarding from a specific IP address? This could work under BGP and Fusion Hub since the cameras all use port 80 and the destination address wouldn’t change regardless of how it’s connected back to the Transit.

@ChrisMT,
I was able to get BGP to work over Wifi and Wifi-WAN. As seen in screenshot. This was from the Transit Duo, and the BR1 as the connection. I was able to connect by Wifi to Duo, and pull up feed from camera I plugged into BR1 LAN. I didn’t open any special ports, but I did add in OPSF routes.

After applying the settings, reboot both devices (think this was my issue the other night). I made sure Duo was up first then let BR1 connect.

2 Likes