Confused by dynamic DNS options - BR1 mini (8.0)


I have the BR1 mini (v8.0) and I’m struggling with the dynamic dns setup for This is typically a trivial setup on other devices but the behavior I am seeing on the BR1 doesn’t make sense. My BR1 is on a T-Mobile connection and is being assigned an “internal” IP that appears to also be a routable IP number which I find to be odd. However, that’s just a side note here…

When one clicks the “?” to the left of the dynamic dns provider setting, a small help screen pops up. Within that help is another option for “disable IP address detection”. Note: I find it kind of odd that a setting like this is hidden in help instead of just being present in the dyndns setup area…

So, based on this, there are 3 ways to set this configuration:

  1. no setting, just email, password and hostname
  2. click the “?” in help and select “Detect Automatically”
  3. click the “?” in help and select “Announce WAN IP Address”

Now, I don’t know exactly how No-IP works but I assumed that at least one of these choices would give me the true “external IP number” for the BR1. But no, regardless of how this is set, the only IP I see on the no-ip web site is the “internal” (and in this case apparently routable) IP number.

Does anybody have any idea on this? I wonder if the no-ip code is not working correctly?


Hi Dave, Dynamic DNS will not work with a cellular connection unless you are subscribed to a static IP SIM card.

It may look like a routable address but it is indeed NAT’d.



Yes, I knew it was NAT’d because it didn’t match the external IP.

I should have added the following: I have a mac behind the BR1 running the client. An nslookup on the mac host name shows the correct external IP. I expected this from the BR1 as well.

Ultimately, I’m trying to create an outbound VPN from the BR1. I’m not sure that’s going to be possible. But, for now, I’m just trying to understand the behavior of the dynamic dns client implementation.

I don’t believe that the issue is with no-ip. I suspect it is a pepwave firmware issue.
I’m having similar confusion with the dynamic DNS update. The IP reported by my BR1 is always the external IP of the last connected ethernet WAN. The pepwave manual (FW8.0 page 90) refers to each WAN type (e.g wired WAN, cellular WAN, reporting the related external IP address. I note that each WAN type has the ability to set a different host to update with the DNS provider.
I suspect that there is a coding error in the firmware that always looks up and reports the last wired WAN external IP rather than the relevant external IP.

OK, I stand corrected … apologies pepwave! My BR1 will report correctly. The secret is using the hidden option mentioned in this post, ie click on the question mark next to “Dynamic DNS Service Provider” and then select “Announce WAN IP address”.
My problem is solved … thanks vronp for mentioning the hidden item.

1 Like


Are you also using no-ip? I don’t believe you specified in your post.

I’m glad my discovery helped.

Thanks again for your discovery … it was driving me crazy. I’m using Verizon cell service with a normal IP (not static) which is why I’m using no-ip DDNS. I’ve forced maybe 20 IP changes and no-ip is being updated perfectly. Please let me know if I can help with more info.


I’m glad it is working for you. It does not work for me with T-mobile, regardless of setting with no-ip. I think the next step for me is to try another dynamic dns client on the BR1.



Sorry to hear that. I presume that you are only adding the no-ip info and only updating via the cellular WAN dynamic DNS info? That was the other thing that I had to do in my earlier attempts to make it work. I even established a dedicated dynamic no-ip address for the cellular wan.

I also learnt that I had to use my no-ip email address not my no-ip user id.

I suspect you’ve done all that already but sharing my learning.

Good luck


Yes, and I also have a dedicated no-ip hostname for the BR1. I tried the client in the BR1 and the results were the same. So again, the external IP number reported by the client on the BR1 does not match the external IP number reported by clients behind the BR1. It is not clear to me why this is the case but at this time, I assume it is a TMobile thing.

In the interest of wrapping up this thread and potentially helping others, I’m making a final post here. The problem I have is a result of “double NAT” being used by T-Mobile. This is what is preventing the dynamic dns services from working on the Peplink device.

I don’t know if this is going to prevent me from being able to establish a VPN of some sort (not Peplink’s VPN) with the BR1 device but I’m feeling like it probably will. I tried for several hours to configure a working IPSec tunnel but was unsuccessful.

If anyone has successfully created an outbound VPN in a situation like this, I would love to hear from you, especially if you are using pfSense at the other end of the VPN.


Dave, you can host a fusionhub solo appliance in vultr for $5/month which will give you a single NAT hop and then outbound VPN will work fine. Made a video about setting uf Fusionhub recently:Pepwave Br1 Mini NAT Type [Video Tutorial Added] - #12 by MartinLangmaid

basically you go from:



But this requires an active InControl subscription as well, does it not?

No. You can configure it all manually, you don’t need a either appliance to have a subscription - although its easier to manage them if you do.

1 Like