Complete and utter failure ☹️

Gday all,

So after applying IC2 country blocking, I lost access to balance 20 web admin and IC2 reporting as offline.

internet was still working then eventually started going down.

I decided to factory reset using the reset button. Completely failed.

Tried multiple times. Still have 2 green lights but doesn’t seem to reboot. It did it once but still had original IP.

Now hard reset just doesn’t work. Holding it down for at least 20 seconds.

Seems it’s no longer handing out an ip so connecting locally via Ethernet is a dead end.

Have I just bricked my new Balance 20?

Anything else I could try?

First thing, unplug the power and let it sit for a couple minutes.

You should be able to connect locally, even if the router is not handing out LAN side IP addresses. After factory reset its LAN IP is 192.168.50.1. If its really not doing DHCP (hard to imagine) you would need to configure a computer to think its also on the 192.168.50.x subnet.

If the factory reset did not take, try to address the router by whatever its LAN side IP used to be before the country blocking rule.

2 Likes

Hey Michael,

Tried all the above. No ping reply when trying with the default IP.

ping replies to previously set IP but connection times out.

I had just added it back to IC2 earlier to test out country block. Added some countries to inbound with a deny rule in incoming firewall rules and it all went south from that point.

I removed the device from InControl and added back.

I have 2 solid greens but seems the hard reset kinda left it in limbo.

I think I’m packing this up and shipping it back. Not impressed.

SIGH… tried one last time… seems this time it took… but factory reset using the reset button never worked. Still had all my configuration in there. Would that be because it was still tied to inControl?

I must have have done about 6 or 7 hard reset attempts. I restored my config to what it was before i applied the country block rules via IC2.

But this is leaving me a little uncertain on the reliability of this unit.

Perhaps you were doing the factory reset wrong. Not blaming you, the documentation may not be perfectly complete. This would be my biggest concern. Being able to do a reset is our Get Out Of Jail Card.

Perhaps you could explain exactly what you did and what you saw. No one ever documents what the assorted lights should be doing during and after a factory reset. Certainly, if the factory reset is problematic, then return the device.

If I had a nickel for every time there was a story like this… By which I mean that you try something over and over and it fails and fails, until one last try. As if computers knew when we mentally gave up and then they started working again. Not the first such story.

I actually didn’t do another factory reset the last time. Simply unplugged it and waited longer, maybe 5 minutes.

Then reconnected laptop locally via Ethernet. This time the web admin came up.

For previous factory resets I was simply sticking a pin in the reset on the front and holding it in for 20-40 seconds. The lights actually never did anything. Only after maybe a minute or so would the status turn red telling me it was “doing something”.

I’ve reset the device once or twice before and never ran into an issue.

I did have remote assistance turned on as well for a current support request. Wondering if that may have prevented it. Initially when it all went down I thought maybe support had started working on it but they assured me they had not done anything.

Makes me a little nervous to drop another few hundred bucks on some AP minis at this point.

:flushed:

If you can, try the pinhole factory reset again (not the reset via the web admin interface) and note what the lights do. This way you know what to expect. This level of detail is never documented for any device, which is why I documented it here for the Surf SOHO.
https://www.routersecurity.org/SurfSOHOinitialconfiguration.php
The Surf SOHO has an advantage, we can see the default WiFi SSID as an indication that it has been reset.

Also, its best to do a reset with nothing plugged into the router. Simpler is always better.

Finally, if the LAN connection fails, try a different Ethernet cable, a different computer and a different LAN port. Trust me on this. Also, check the LED indicators on the router Ethernet port and the computer (if the computer has them, many do not).

1 Like

FYI… I re-eabled IC2 controlled F/W rules with country blocking… as soon as I did… my B20 went offline on the IC2 dashboard… and I can no longer connect to local web admin.

Internet is still working, and B20 status lights are green.

I’ve opened a ticket with support.

Not sure if its something i’m doing, or there is a bug with IC2 country blocking push.

Really strange. Perhaps a typo in a firewall rule is blocking your LAN side access to the router. Wild guess. If you have no VLANs, forced to reset again. If you do have VLANs, try to get at the router from a VLAN rather than the untagged LAN (assuming you did not block this on purpose). Again, a guess. If there is a next time, just block one country and make it a small one.

1 Like

Ok another factory reset failed. Nothing connected and:

  1. Hold the reset for 20 secs or so.
  2. Status and power stay green for about a minute or two
  3. Status goes red and stays red for at least 10 minutes
  4. Status light goes off for a few minutes
  5. Status light goes green
  6. Local lan connection cant get an ip. Getting a 169.xx address.

Hello Stephine @stego,
Out of interest, what country are you in and have you reached out to your Authorised Local Peplink Partner as they may be able to help you?
Happy to Help,
Marcus :slight_smile:

Hi Marcus @mldowling,

The B20 was purchased from Amazon in Canada. I suspect there was something wrong with the unit given the huge discount. I ended up returning it for a refund.

1 Like