Client List - please show all LAN->WAN clients (regardless of subnet)

I run two balance routers. A Balance One Core (primary router for the house) with two WAN links active. I also have a Balance 30 that is used for video games (PC and XBox) that has one WAN connected to DSL and the other WAN port connected to a LAN port on the Balance One (using IP Passthrough). The Balance routers use OSPF to exchange routing/subnet information.

Balance One - 192.168.20.0/24 (Vlan0), 192.168.21.0/24 (Vlan3)
Balance 30 - 192.168.19.0/24

My client list on the Balance One only shows the 192.168.20.0/24 and 192.168.21.0/24. No clients from 192.168.19.0/24 ever show up. I can only see the WAN IP of the Balance 30.

Would it be possible to set up an additional LAN subnet on the Balance One and have the clients in 192.168.19.0/24 show up in the list? If not, I would like to request that all LAN ->WAN traffic be displayed in the client list. I understand that the MAC addresses for “unknown” lans would be blank, but the IP and data usage should still be there.

Is there a better way to get a complete client list between the two routers?

I would recommend the following changes to accomplish this:

  1. Do not use IP passthrough on the B30 WAN as the WAN IP will be passed to only one LAN client. Reconfigure the B30 WAN that is going to the Balance One LAN to use IP forwarding by clicking the “?” near routing mode. This will get rid of the NAT.

  2. On the Balance One configure a LAN DHCP reservation for the B30 WAN IP address so it will not change.

  3. A LAN static route is needed in the Balance One Core for the 192.168.19.0/24 network, pointing to the Balance 30 WAN IP address.

2 Likes

Your instructions are confusing. I am already running IP pass through on the WAN-LAN link from the B30 to the B1. The B30 WAN link uses a static IP outside of the DHCP pool. Routing is exchanged using OSPF and is working. Everything works well except for the useage from clients in 192.168.19.0/24 do not show in the client list.

My issue is that the dashboard will show heavy utilization on my WAN links, but I don’t see the clients using the bandwidth. I have to log into the second router to identify the source of the traffic.

Also, I can see the active sessions complete with IP addresses from the 192.168.19.0 network on the B1, but this doesn’t tell me client usage. Only that the router knows about the connections, it just doesn’t include these sessions for display in the client list. My guess is because the B1 doesn’t feel that the 192.168.19.0 is a local lan.

Do as Ron suggests above I wouldn’t use IP Passthrough its a non standard approach to what you want to do.

Routers are meant to route traffic between subnets - passthrough if for specific cases where you want to bridge a LAN client to the WAN.

So turn off ip passthrough, and instead set your Balance 30 to do IP forwarding on the WAN connected to the Balance one. Then your Balance One can route return 192.168.19.0/24 traffic via the WAN IP of the Balance 30 but more importantly the Balance One will then see the source 192.168.19.0/24 subnet as NAT won’t be in use and show those addresses in its client list as you asked for.

1 Like

my apologies, I am using IP Forwarding (not IP Passthrough) already. To be honest, I don’t have the option for IP Passthrough - I just thought that was what it was called. The only other option is NAT. Is something associated with Drop-In mode called IP Passthrough?

The 192.168.19.0 subnet does not show up in the client list on the Balance One. I only see the actual Balance 30 WAN Interface IP in the client list.

To be clear, I have The B30 Wan connected to the B1 LAN. The B30 is using a static IP outside of the B1 DHCP range (but inside the subnet boundaries) for the WAN connection. The Wan link is using IP Forwarding (not NAT). Routing information is shared using OSPF on that link. The B30 is aware of the networks on the B1 and the B1 knows how to route traffic back to the B30. Everything works. Traffic is routing correctly. It is just that the client list on the B1 does NOT include the client IPs inside the B30.

The “Active Sessions” page on the B1 correctly reflects all the connections for every subnet (even the one on the B30). The B30 WAN IP shows in the client list (but only if I check for firmware or if it does an NTP update).

Sorry for the confusion. I didn’t realize that there was a different feature named IP Passthrough. I have been using IP Forwarding for a long time.

I have no comments re. your network topology :slight_smile:

Taking that it is what it is, one way to get the client list for the two routers is to employ InControl2. Register the two routers, and define them as an IC2 group.

Then open the groups window and select “clients.” That will provide a list of all the clients of all (ie., both) the routers in the group.

Cheers,

Z