Cellular will not connect on my 20X

I can’t get Cellular to connect on my newly acquired Balance 20X. In the Dashboard it shows Cellular as searching and says “Obtaining IP address…” (See photo.)

The SIM card shows up as functioning and all details are listed in the router interface. I successfully used the same SIM (T-Mobile) with no problems in a Peplink BR1 mini. I am able to connect to the 20X router via wifi and ethernet.

Any assistance or ideas would be greatly appreciated! Thank you.


Have you tried enabling “Data roaming” in the Cellular settings?

Even if though I’m not ACTUALLY roaming I had similar issues with some SIM’s in our Balance 20 X. I guess the SIM is not reporting exactly the same ID as the network, so would get stuck on “Obtaining IP address”.

Worked for me, so worth a try.


Hi. Initial steps:

  1. Update FW to current (which is 8.1.1.)
  2. Double- check your APN and ensure it has been entered correctly for the plan you purchased.
  3. Ensure your data plan is intended for use in routers.

Let’s see what happens with these three steps.

As to the last point, there is a t-o-n of discussion about the last issue here on the forum. To be brief, the “cellular data situation” in the USA is a total mess. Often “some entrepreneurship” is required" – except for those with unlimited budgets and/or infinite patience.


I tried it, thanks Mike. I appreciate you taking the time. But unfortunately it did not work. Although it did change the wait message to “Connecting …” from the prior “Obtaining IP address.”


Thanks, Rick!

It’s a T-Mobile unlimited data plan and the same SIM works in a BRI mini.

I will check the other two now. Have to disconnect from this lan.


Updating the Firmware to 8.1.1 did the trick. I had to manual update due to an IP conflict. But it worked. Thanks very much, Rick!

1 Like