Can't access website behind Balance One on local network

I have a Balance One, it works great.
Behind the Balance One I have a small website (local address
The website is accessible (the A record has been created) from the Internet,
but not accessible on the local network (unless I use

Does this has to do with static routing? DNS?

Any help would be appreciated!

Do any of the 3 routers have NAT enabled? In theory, you should be able to access a WAN IP address from within the LAN, by something called “hairpin NAT” - it generally should work, although there are some weird ege cases: with port forwarding and also with firewall rules

Actually, all three of the routers have NAT enabled.
The website is accessible from the Internet, not locally unless I use
the IP associated with the server.

My guess would be that double NAT is interfering with NAT hairpin, but I don’t know to fix it, if so.

Under LAN > Network Settings > DNS Proxy Settings try entering the name and corresponding IP address then add and save it.

1 Like

Thanks for the replies.

I tried the solution from AskTim, it didn’t work.

The website is viewable from any other network, just not locally, unless I use the IP address,
which generates a browser warning because the certificate is not

It is not clear what you mean by “local”. Do you mean from a device connected to the Balance router or to router 1 or to router 2 or some combination of them? That is, from what subnet are you trying to get at the server at

If your Peplink router is configured to do local DNS, then it should be simple to create an entry with any name that points to your local server.

1 Like

Thanks for the reply.
From a connection from router 1 or 2.
In the local DNS Peplink setting, I do have the host name listed with

What are the devices behind router 1 and router 2 using for DNS? Is it a public service like OpenDNS or are the routers themselves doing DNS?

Then too, all this is moot if you are using a web browser with Secure DNS. In that case, nothing in any of your 3 routers matters. Likewise, Android with Secure DNS will also not care about the DNS settings in any router.

Old insecure DNS was simple. New secure DNS is complicated. On an iOS device it is all but impossible to know what the DNS environment is.

1 Like

The routers are doing DNS.

Perhaps verify the DNS being used using a couple of the tester pages here

So both router 1 and router 2 have hard coded DNS entries for something.something that is assigned to

Just curious, have you to tried to access the server by name from a device on the 192.168.1.x subnet? My guess is that it would work.

1 Like

What do you see in the browser when you try and access using the domain name from a LAN device and it fails? The first thing I’d check is the server config and logs and see whether the request gets there and is blocked by a a server side config.

1 Like

Router 1 & 2 use the Balance One for DNS.

The server can be accessed from the 192.168.1.x subnet by name.

In Chrome: “this site can’t be reached”
site took too long to respond

On the server side, In the event log…
“The DNS server encountered a bad packet from Packet processing leads beyond packet length.”

Again, try a couple DNS testers from computers behind router 1 and router 2. And, try a couple different browsers too.

And verify the DNS server being used on a computer or two behind router 1 and router 2 without a browser. On Windows, you can do this with nslookup. Not sure the command on other OSs.

Also, many routers have a network debugging section with typically ping and traceroute. Perhaps this can be of some use on router 1 and router 2.

1 Like

Server side? Do you mean your server at or the Balance router?

1 Like