Can't access WebUI unless logged in as Admin on Windows 10

Can’t access webUI unless logged in as Admin on Windows 10. Anyone know how to get around this?

Why not? What happens when you try?

1 Like

When I do this from an Admin account a message pops up from Kaspersky giving me a warning that the site isn’t safe but gives me the option to proceed to site anyways. On the standard account it just flat out blocks me leaving me no option to click to proceed.

Ah. I suspect that’s Kaspersky being super protective when you’re not an admin.

Try accessing your router using this address it has a self signed certificate for this domain (which it replies to) installed and that should then let you access it.

1 Like

This is what I got with the captive portal link.

Sorry just checked and I have manually added it as a local DNS entry on my router.

To do teh same, login to the webui, navigate to Network > LAN | Network Settings and add an entry in the Local DNS records section that has as the host name and as the IP address. Then click Save at the bottom and apply changes at the top.


Thank you. I will give this a shot and get back to you.

This method didn’t work for me. I am going to have to contact customer support for my anti virus software to figure out how to allow that address through on my standard account. Or possibly change something in Windows users settings. I appreciate the help.

I have no issues, I never run Admin-level unless absolutely necessary.

1 Like

The fact that I can only access Peplinks WebUI from an admin Windows account is due to Windows itself. Some people have reported not being able to access the webui for their routers after updating Windows.

What I know for sure is that this isn’t caused from: anti virus software, vpn or browser type.

I have tried multiple solutions and nothing has worked. I am going to have to play around with the settings and see if I can figure it out.

This isn’t a Windows issue either apparently.

I tried this again and it worked. Don’t know why this didn’t work the first time. Thank you.

1 Like

Woke up this morning and I can’t access again from a standard account. I logged in from my admin account and the local dns record was still there. I am now at a loss. I don’t know what to do.

SOLVED IT=D I had my VPN setting set to (invisibility on LAN) which makes my devices invisible to network devices. :rofl: So having that toggled on disallows access to router UI from standard Windows accounts.

1 Like