Cannot get health checks to pass - Balance 30


#1

I just got a Balance 30 for our office and am super excited to get it set up. We have a Comcast Business Class Internet connection, and a new Verizon FIOS connection. Both work fine on their own. Both are configured to be 192.168.1.1 default gateways, and both are set up to serve DNS from .1.1 as well. I can take our main switch Ethernet cable and swap it back and forth between the cable modem and the FIOS router and everything just “works” as far as folks on our LAN reaching the Internet.

Today I tried to set up the Peplink. I set up WAN ports 1 and 2 to be DHCP. I hooked up the Comcast to WAN1 and the FIOS to WAN2. Both ports successfully got a DHCP address from their respective connections (192.168.1.190 and 192.168.1.20 respectively). But… They both intermittently fail DNS health checks. It happens over and over. I get a message:

Failed to receive DNS response from the health-check DNS servers for WAN 2. But public DNS server lookup test via the WAN passed. So please check the DNS server settings.

I have tried so far:

  1. Lengthening the timeouts for the DNS check
  2. Checking the box to allow external DNS checks
  3. Changing from DNS to HTTP health checks, and pointing it at www.yahoo.com and/or www.google.com
  4. Changing the link speeds from 1000/1000 to 100/100
  5. Changing the physical port to 100 Full Duplex
  6. Trying to use WAN3 instead of WAN2 for the FIOS (shot in the dark - bad port? nope)

None of the above have worked. Can you please help me troubleshoot how to get the health checks working? Please let me know any/all info I need to provide beyond this. Thank you,

-Andrew


#2

The Balance LAN interface is in the same network and it does a NAT from LAN to WAN so there is a conflict. Simply change the LAN network to be something other than 192.168.1.0/24 and it should pass the WAN health checks.


#3

What I had liked about my setup (having Comcast, FIOS, and Peplink) all 192.168.1.1 was that I can hot swap during the day with little outage. No need to go to everyone’s machine (20 or so) and swap them to a new default gateway. I think I understand why it is failing from your description, but I need to come up with some way to change the minimum amount of parts to make it work.

Could I instead change the Comcast cable modem to be 192.168.2.1 and the FIOS to be 192.168.3.1, and leave the Peplink as 192.168.1.1? Would that work? Then I only need to (quickly) change those two addresses from their respective admin screens. Using a rapidly swapped ethernet cable and laptop. Please forgive my admin ignorance I’m much more Dev than Ops. Just know enough to squeak by. Thanks in advance, -A


#4

Sure. You can do that or configure the modems to be in bridged mode to solve this problem.


#5

The configuration of a Comcast Business Gateway appears to be non-trivial to put it in Bridge mode. The FIOS looks a little easier to do, but I want them to be relatively “the same”. In the end I went with setting the Comcast to .2.1 and the FIOS to .3.1 and leaving the Peplink 1.1. It’s all working, health checking, load balancing, etc. Nicely done Ron, thanks for being so responsive! Color me a satisfied customer.


#6

in Comcast Business Gateway you can put your Peplink in DMZ IP, this will expose your device to outside. this is the best you can do with Comcast Business Gateway