Cannot Access Peplink Web GUI from the LAN Network

Hey i am using 10.100.0.0/16 subnet in my LAN environment and Peplink is connected with Firewall.

P2P IP between firewall and peplink is 192.168.40.0/24
192.168.40.1 ( Peplink )
192.168.40.13 ( Firewall )

I am unable to access the Peplink from subnet 10.100.0.0/16

Thanks

Assuming you are using IP forwarding and not NAT, whichever device your LAN environment is behind, the other device needs a static rule to know where to send the return traffic for 10.100.0.0/16

Hey Martin - Peplink is directly connected with firewall so why do i need to add route in order to access the Peplink ?

Thanks

Because the Peplink needs to know the route back to 10.100.0.0/16. All it knows about on it’s 192.168.40.0 network is 192.168.40.0. Everything else is on the “outbound” side, its default route, as far as it knows.

The firewall knows where 10.100.0.0/16 is, because that’s a directly-connected subnet. The Peplink doesn’t know to send 10.100.0.0/16 traffic to the next hop at 192.168.40.13.

Both @James_Seymour and I are assuming that the problem is caused by your firewall doing IP forwarding from your 10.100.0.0/16 LAN to the peplink on the 192.168.40.0 lan. So it looks like this:

The other potential issue is that your firewall might not like having a private subnet on its WAN. some have firewall rules that specifically block this. Check your firewall logs to see what’s going on.

[quote=“MartinLangmaid, post:5, topic:41004”]
The other potential issue is that your firewall might not like having a private subnet on its WAN. some have firewall rules that specifically block this.
[/quote]Come to think of it: That’s probably the problem.

@Nauman_Idrees, can you access the Internet from 10.100.0.0/16? If so: Then I have to amend my prior statement: The Peplink knows how to get to 10.100.0.0/16, but the firewall is probably blocking traffic to/from 192.168.0.0/16 as invalid on the WAN side.