Can only get to very limited internet sites after switching from Verizon to Sprint, Surf Soho


#1

A few months ago I moved from a Cradlepoint MBR95 to a Pepwave Surf Soho. Was using a UML290 modem on Verizon. Yesterday I switched to Sprint, with a 341U modem. The modem works great on my laptop, but when I use it in the Surf Soho, it did not seem I had internet at all, even though there were no error messages, and the tray icon shows internet. Then I found I could only get to a very limited couple of internet sites. Facebook worked, so did Gmail, but nothing else I tried.

I put the modem back into my laptop, works just fine. (I have a very strong signal to the modem, with a dual Yagi antenna attached MIMO)
I tried rebooting the Surf Soho a couple of times, no luck.

I pulled my old Cradlepoint MBR95 out, and it works just fine. So now, I am operating on the Cradlepoint again. Can surf to any site on any device on WiFi.

What could be the problem with the Surf Soho? I like it much better because of the higher WiFi power, and the far greater options for monitoring.

It is using firmware 6.2.2. Would a firmware update help? If so, how do I do that if I go back to it since it will not allow me to get to the Peplink site. Not happy with it sitting on the shelf unusable at this time.


#2

Look like your connection as below. Do correct me if I am wrong.
Users ))) Surf Soho —> Internet

Please do me favor below:-

  1. Pick one of the websites you failed to access.

  2. Login to Surf Soho then navigates to System > Ping.

  3. Ping to 104.24.4.37 and www.peplink.com. Do let me know both results.

  4. If you able to ping www.peplink.com in step 3 above, users connected to Surf Soho able to ping www.peplink.com and browse www.peplink.com?


#3

Tried the Surf Soho again this afternoon, worse than yesterday. This time after boot, logged onto router and got “WAN failed Smart Check” Device display shows LTE, with 5-6 bars signal strength.
Rebooted again, same result.
Turned off Smart Check, then it showed “Connected to Sprint”, but had no internet connection at all. The couple sites that worked yesterday did not work this afternoon.
Tried Ping to 104.24.4.37, got “5 packets sent, 0 received, 100% packet loss”. Tried ping to www.peplink,com, got “Unknown Host”.
I went back to my Cradle Point MBR95, as usual it connected right away, no problems at all. I tried my laptop again, connected right away, no issues.

Something is severely amiss with the Surf Soho and the 341U modem!

Thank goodness I did not get rid of my Cradle Point when I bought the Surf Soho, or I would be in deep trouble now.

P.S. The leds on front of the Surf Soho show Green for Status, Flashing Green for WiFi.


#4

Hi,
I had almost the exact same issue as you did to start but using the pepwave surf on-the-go instead of soho. My 341u would connect and I could get gmail and facebook, but not yahoo or zillow as examples. I could however ping all of them, and usually got 3/4 packets back from all of them. I called peplink and even though I had the most recent firmware 1.0.26 from the website, they said I needed 1.0.27 to be able to use the 341u modem and they emailed me a link to it. I do think it’s an issue with using the 341u modem, so maybe there’s a newere firmware for the soho that will fix the issue, as once I loaded the 1.0.27 firmware it all worked fine. They did mention I needed to be sure to have the 341u in normal NAT/router modem and not IP Passthrough.


#5

Hi,

Base on the description given, look like this is more like the driver compatible for the 341U USB modem. Base on partner/customer feedback, the 341U should work well using the Surf Soho latest firmware. Please upgrade the Surf Soho using the latest firmware and see whether this will resolve the issue.

You can download the Surf Soho latest firmware by using the URL below:
http://www.peplink.com/support/downloads/firmware-6-3-1-and-user-manual/

Else if the issue still persist, please open a support here for the team to further check.

Thank You


#6

I downloaded it, will try it when I get home tomorrow evening.
I had another thought, noticed a reset button on the back of the router. Would a factory reset likely help, since it had been working with a UML290 previously?


#7

Hi,

This is more like driver compatible issue for 341U USB modem and nothing related to UML290. Latest firmware had improvement for the USB driver that should solve the reported issue. Please upgrade the Surf Soho using the latest firmware and see whether this will resolve the issue.

Thank You


#8

Will open a support ticket. Upgraded to the latest firmware (6.3.1 build 2023) things seem to be even worse now. It seems to “see” the modem, but keeps cycling through “detecting device”. When I click on details, it shows “netgear modem”, but no internet connection at all.

Back on the Cradle Point again. I sure want the Surf SOHO to work! The Cradle Point is reliable, but weaker WiFi, and little control and monitoring, which is why I purchased the PepWave.


#9

Opened a support ticket, but they want to connect to it in the middle of the night, but I do not see how that is possible because the whole problem is that it will not connect through the 341U modem.

I just got home, and tried everything again. The Surf Soho absolutely will not work with the 341U Sprint Modem!
I tried the following:
> 341U on CradlePoint MBR95 router, working great
> Checked firmware on 341U, up to date
> Did a factory reset on the Surf Soho, booted it, made sure it was on the latest firmware, yes. 6.3.1 build 2023
> Put the 341U modem on my laptop, works great.
> Checked signal on 341U: RSRP –85, RSRQ –9, RS-SINR 29 Very good signal, using two YAGI antennas MIMO
> Put Verizon UML290 modem on Surf Soho, works great.
> Put 341U modem on Surf Soho, does not work. Get detected device, goes away, does it again, continuous cycle. When detected device is on, click “details”, shows “Netgear Modem”, but will not connect.

The Surf Soho works just fine with the Verizon UML290, as it has since I bought the Surf Soho in February. It WILL NOT work with the Sprint 341U modem.
The 341U modem works just great on the CradlePoint modem, and also on my laptop, so the issue is not with the modem.

I really want this to work, as Sprint is 3 times as fast as Verizon, considerably less cost for a 30Gb plan.


#10

Hi,

Let’s work it out using support ticket as we have more tools to work with the devices.

We have customer using Netgear 341U that working fine with Surf SOHO. Please follow the instruction given by support team and you should able to make the USB modem connected with the Surf Soho device.

Thank You


#11

Was this ever resolved?


#12

The problem has been resolved. This regards to AirCard 341U modem mode setting issue.


#13

I am having the exact same problem. What can I do to fix this? Need to get online asap! I’ve updated my SOHO firmware and still nothing…