Can not register Verizon SIM on MAX BR1 Pro 5G

The MAX BR1 Pro 5G will not register a Verizon SIM. I went to a corp owned Verizon store and went all the way to Tier 2 support for them to tell me I needed a special SIM for 3rd party 5G device like this Pepwave. Received the new Verizon SIM model M2MTRI-NONRUG-GT-A they said I needed and it still will not register. Please help

Tell them to register it to any old hotspot they have laying around the store. Then pop the sim in the pro5g. I had to do it that way with two vzw data sims. No special sim Required but their consumer tool will only work with nighthawks and the other consumer grade hotspots.

1 Like

I did that just now (and Verizon did at their corp store with one of their HotSpots) with my old JETPACK 4G LTE MHS MIFI 7730L, it registers the new SIM as mentioned above but the MAX BR1 Pro 5G will not register even after the SIM works in the old Jetpack.

It should work. The SIM only needs to be activated on a “supported device” and then can be swapped into any other device, so long as it’s compatible with the network.

What plan are you using? It was rumored that legacy grandfathered plans could no longer SIM swap into different devices.

I am on a business plan LTE BUSINESS INTERNET 50MBPS 150GB/300GB $209 that I just signed up with two days ago.

what does the 150/300 mean?

I had essentially the same problem with my MAX BR1 Pro LTE - I tried to add a line for it on my family plan like I did several other LTE routers I’ve used and I got some sort of unhelpful error telling me to call Verizon. First level support could not add it either but second level support could after fudging something - I believe the device type in Verizon’s system.

The device works fine, and I decided to upgrade from the “Essential” plan that I used for testing. I went to upgrade the plan on the Verizon website and got an obscure “try again later” error in bad English. Tried several more times, and it never worked. I called Verizon, spent an hour on the phone going through multiple levels of support, they couldn’t upgrade my plan. They submitted a ticket and I’m waiting to hear back (this was over a week ago).

Clearly there is something wrong with how these routers are defined in Verizon’s system, it would be nice if Peplink and Verizon would work that out.

Meanwhile, I had a SIM card for a Netgear router that I added to the Peplink and it works fine - I think if I upgrade my plan on a non-peplink router and then switch the SIM card it will work fine. But I was waiting to hear back from Verizon. Meanwhile I have 2 SIM cards each with the “Essential” plan that I can switch between in the Peplink to get 30GB a month.

How do we communicate to Peplink that there is a problem here? I’ll be calling Verizon to check on my ticket soon, not looking forward to running that gauntlet again.