Can not get into Surf SOHO via SSH


#1

I tried to SSH into a Surf SOHO firmware 7.0.1 for the first time and the router did not take my admin password. The password had special characters in it, so I changed it to just numbers and letters. Still can not get in.

Using Putty v0.70 from a Windows machine. Connect to router, enter admin userid and admin password, then get error “server unexpectedly closed the network connection”. SSH is from the LAN side on a non-standard port, if that matters.

User Manual has no additional information about SSH access, just how to enable it.

Putty SSH log file is below, nothing useful, at least to me

~=~=~=~=~=~=~=~=~= PuTTY log 2017.10.07 19:11:17 =~=~=~=~=~=~=
login as: michael
michael@192.168.9.9’s password:

UPDATE: same problem logging in with SSH to a second Surf SOHO. This time, firmware 7.0.2 and using WAN side rather than LAN side. First router was HW2, second MK3.


#2

Just tested this and found I couldn’t access it either with my custom Username (ie not ‘admin’) and password that is set for the WebUI.

However if I used ‘admin’ as the username and my webui password for my administrative account on the device it logged in successfully. Smells like a bug to me.

Just a note that it is a very restricted userspace when you access via SSH. You can only run allowed commands - guide here: http://download.peplink.com/manual/CLI%20SSH%20Guide.pdf


#3

Thank you. Thank you. Thank you.
Using user “admin” for SSH with my custom password, worked for me too.

It sure does seem like a restricted environment. Thanks for the link to the documentation.


#4

Update: I have been told that this is a bug slated to be fixed in the next firmware update.