Cable modem connection problem is not dead yet

Issues with Peplink routers connecting to assorted cable modems go way back. Yet, just as an FYI, it happened to me again today.

Router was a Surf SOHO running latest edition of firmware 8.1.2. I had to power cycle a Netgear CM600 cable modem to move it to a new surge protector. When powered on the router was hung at “connecting…” and never connected to the modem. The modem was happily connected to the ISP. After rebooting the router, it still failed to connect. The next modem power cycle worked fine and a router reboot after that also connected fine. So, its intermittent, perhaps the worst type of problem.

This is seriously disappointing that the problem can still exist after all this time.


@Michael: Just curious … which ISP are you using?

1 Like

Spectrum is the ISP

1 Like

I have had the same problem with my Netgear CM600 modem on Comcast in the past with my Surf Soho running older firmware. A Balance One Core has replaced the Surf and if my memory serves, I have also experienced the Connecting problem with it.

After reading Michael’s post, I tested power cycling on my CM600 modem. While I couldn’t reproduce the Connection hang problem, I was reminded of another problem I sometimes have when my Comcast connection gets stuck at about 10% of my maximum download speed. I reproduced this twice this evening after power cycling the modem; 34Mbps instead of 330Mbps.

I suspect this is a problem with the Peplink handshake with the CM600 modem because when I unplug the Ethernet cable between the two and reconnect, the problem goes away. It also goes away if I power cycle the Balance One.

It seems evident that Comcast is limiting the download speed, not the Balance One. The modem connecting to different channels won’t explain this (the CM600 has 24 download channels out of the maximum of 32 channels supported on cable). I suppose the number of channels being connected could be less than 24 when the problem occurs which would be consistent with it always being around 34Mbps. I haven’t checked the modem, but probably should in the future. But why would that occur? The only theory I can come up with is the Balance One handshaking with the CM600 is different somehow, affecting how Comcast dynamically configures the modem, possibly based what it believes the identity of the router is (MAC address??).

I welcome other comments on a problem that seems so bizarre that I previously elected not to mention it, but do now in case it helps shed any light on the Connecting problem. (The 34Mbps state also occurs occasionally when I have not power cycled the modem and I am on a UPS.)

1 Like

We did receive a few similar cases. We are working with the partner/customer to investigate it. Based on the current finding, the same symptom can be found. We failed to get a DHCP Reply from the ISP when the problem is occurring. We also see there is a lot of IPv6 ICMP packets sent from the ISP. So, this shows that the WAN link is up but not sure the reason the ISP is ignoring our DHCP Request. You may do Network Capture from the support.cgi page - https://<LAN IP>/cgi-bin/MANGA/support.cgi to confirm whether you are seeing the same symptom.

@Michael234, can you help to open a ticket for us to investigate? Your previous problem is resolved in the 8.1.1. We wish to confirm whether it is a new problem.



Hi @Mark9. We have a customer using a TP-Link modem with Comcast that exhibits the exact behavior you report. @TK_Liew and others are actively working on this. Our strong impression is that this is a Comcast issue but – unsurprisingly – we have not been successful in getting Comcast to help in any way.

Meanwhile, I’d urge you to follow TKs’ advice and either PM him a packet capture, or submit a ticket, post the number here and turn on RA so the support engineers can take a look.

1 Like

@Mark9: I suggest looking at the Ethernet stats on the support.cgi page. It will also show the speed of the WAN port. And, check the event log on the modem. It really helps to be somewhat familiar with the modem operation, both checking the active channels up/down and the log. Understanding the modem log is beyond me, but you may find a message that only happens when things slow down.

Since you are on a UPS and the slow speed happens sometimes out of the blue, the modem is a bigger suspect than the router. By the way, the best UPSs are line interactive. The standby ones are cheaper but not nearly as good. Think load balancing vs. failover.

If its the router causing the slowdown, look at the load balancing setting, even if you have only one WAN connection. Ten percent might be an issue with load balancing and the router may be doing it on purpose. Also, for the WAN connection properties, check that the router knows to expect 300Mbps.

@TK_Liew Ticket 21070899 has been opened for this. It has two diag reports with network traces. Unfortunately the first was done after the problem happened, so not sure if that is helpful. The second was started with the modem powered off, but it shows a normal working connection after the modem was powered on. Hopefully that can be of some use. Intermittent problems are the worst.

Not to be a back seat driver, but if a DHCP request is not responded to, at some point, should it not be re-issued?

And, more importantly, this has happened enough that a log record or two should be generated with some type of debugging info. Just knowing that the router is “Connecting…” is not enough information for either you or me. Connections happen very rarely, so an extra log record or two or three about the various stages of the connection seems like a good idea. Something like: connection phase 1 started, connection phase 1 ended, connection phase 2 started, etc.

1 Like

I will work on getting a Network Capture and opening a ticket.

@Michael234 I don’t believe that I have load balancing issues as I configure my Balance One with Priority for my Comcast WAN so it is used all of the time and only fails over to my DSL WAN when Comcast fails, or there is Connecting issue on Comcast. That said, I can’t explain why I was able to reach my CM600 modem login page and my DSL modem login page through the Balance One router from my PC given my Priority setting. I would love to understand why I am able to reach my DSL modem login page when my Comcast WAN link is up.

The CM600 Event Log doesn’t show anything since May, so no help there. My WAN connection settings for Comcast are 1Gbps Download Bandwidth. I will look at the speed of the Ethernet on the support.cgi page the next time the slow 34Mbps download speed situation occurs. I would be most concerned if it is not Full Duplex. It shouldn’t make much difference if it is 1Gbps or 100Mbps in terms of explaining 34Mbps.

@Michael234, I will follow up with you in the ticket. Thanks.

1 Like

Hi @Rick-DC. Does your customer’s TP-Link modem ever get faster with no intervention (power cycle, cable disconnect then reconnect, or reboot the Peplink router)? This is something that I am going check out.

I am beginning to wonder if this is possibly a Comcast node congestion policy as I was unable to reproduce my slowdown problem last night when power cycling my CM600 modem. As I have noticed it most often on Sunday evenings (video streaming in the neighborhood?), maybe I will experience it again by then.

I had this issue the other day with a TP Link modem and a Balance 20x on Comcast. The B20x would just show “connecting” on the WAN. What I had to do was unplug the cable modem from coax and power for about 10 minutes. Then I reconnected everything and it worked fine…

The modem was in bridge mode. I think what is happening is the modem locks onto the MAC address of the last router. So it needed to be cleared out and leaving the modem powered off to pick up the MAC of the new B20X seemed to fix it for me. A simple quick power cycle of the modem won’t do it.


Hi @Mark9. Short answer: no. At this point I think we are likely confronting different issues.

The issue we’ve been dealing with is much more similar to that raised by @Biggen. However, in our case the TP-Link modem and Comcast worked OK with a Balance One Core and a 210 but not with a 20X. My understanding is that the Peplink support engineers see the 20X properly requesting an address via DHCP but the Comcast is not responding. (As expected, Peplink’s support is world-class and Comcast’s is zero.)

What I don’t think we tried: leaving the modem powered-down for a longer period of time.

1 Like

These days Cable Modems are generally configured by ISP’s (via loading a DOCSIS config file down to the CM) with a Max-CPE (customer premise equipment) of one so that only one IP address is allowed on residential service (business service allows more). So power cycling the modem should allow a different MAC address (for the 20X in your case) to go through the modem to the CMTS (cable modem termination system).

However, the CMTS has its own Max-CPE count. As best as I can tell, it is not reset when reloading the DOCSIS config file to the CM during a quick modem power cycle, leaving the CMTS count at 1 while the CM is zero. Apparently powering down the cable modem for about 10 minutes did take care of reducing the CMTS Max-CPE count to zero, thus finally resulting in a DHCP response to your 20x.

Anyone with more knowledge than I have in this area is welcome to comment and correct my statements.


I believe your understanding is correct. What’s puzzling is why one could transition from Balance 210 to 20X and have it fail but going the other way would result in success. Next time I am at that location I’ll try a looooong power-down, as per @Biggen’s experience. Never had to do that before but the logic makes sense.

EDIT: Here’s a link which describes that parameter. Although it references DOCSIS 1.1 I’d guess it may be continued into 3.0 and 3.1? This document describes the Max-CPE count as being zeroed on a simple reset of the modem or on application of the clear cable host command. Well, it appears that the first option is not happening quite the way the document describes and I don’t know that we have the access needed to use the 2nd alternative. If a loooong power-down is required I’m wondering how their field techs perform service (e.g., connecting and disconnecting their notebook, for example) – must really slow the process down (unless they can either get into the head-end to issue a command, of course.)

As you say, comments and corrections are welcome.