BR1 IPsec VPN to Sonicwall behind MAX HD2


I’m trying to create an IPsecVPN between a BR1 Mk2 in a very remote location (Verizon cell only) and a Sonicwall TZ500 that sits behind a MAX HD2. I’ve spent many hours with many permutations trying to find a connection.

I do have a PepVPN between the BR1 and the HD2 which works wonderfully but the HD2 doesn’t provide the level of protection that we need.

All devices are on dynamic IPs and I’ve been testing with aggressive mode.

I already have an IPsecVPN from the TZ500 to a different Sonicwall in another location.

I suspect that I have 2 challenges to overcome … the local and remote IDs. The BR1 IPsecVPN has a field for each but the Sonicwall is looking for either

  • IP address
  • Domain name
  • email address
  • Firewall identifier
  • key identifier
    My first question is which of these fields should I specify on the Sonicwall and what should be in it?

Secondly, I’ve read other posts about the field needing to contain an @ symbol but don’t know if this is on the Pepwave, the Sonicwall or both?

Thanks in advance.

OK, so I found the solution and a problem.

For anyone else setting up an IPsecVPN from a Pepwave to a Sonicwall:

These settings worked for me with dynamic IPs on all devices and with IKEv2 or aggressive mode on IKE.

The problem that I still have is that I can’t make an IPsecVPN work over Verizon.

Any ideas please.