Bonjour Forwarding troubleshooting

G"day,

having problems with Airplay and Bonjour Forwarding. Balance 20 router and a Surf SOHO as an access point. Lan and vlans replicated to Surf SOHO.

My airplay device is in IoT Vlan and I have enabled Bonjour Forwarding service from it to my mainLan.

My airplay device is hardwired into an Access port tagged to IoTVlan on the SOHO.

My iPhone is on the mainLan wifi, and the airplay device appears in my airplay list but cant connect.

I can airplay if i connect my Iphone to the same subnet.

I have also disabled Layer 2 isolation on the IoT Vlan.

Any tips or leads?

Anyone else successfully using Bonjour Forwarding on firmware 8.1?

Please share how the physical connection looks like between Balance 20 and SOHO. If you can provide a physical network diagram then will be great.

1 Like

Not very good at drawing network diagrams… but I’ll look into it.

Just na FYI… I tried direct connect to Balance 20 Lan port (Access: VLAN21)… plugged in Airplay enabled hometheater receiver, confirmed it gets an IP in the vlan (10.57.21.52) …

Iphone accessing from MainLan…AirPlay device appears in the list, but connection times out.

Here is my Vlan AP configuration:

Screenshot from 2020-08-21 11-57-10

Note i have tried with L2 isolation unchecked, still did not work.

Connection between SOHO and B20:

SOHO LAN PORT 1 -> B20 LAN PORT 4

SOHO

  • LAN port 1 TRUNK ANY

B20

  • lan PORT 4 TRUNK ANY

My meager attempt at networking diagram :slight_smile:

Hello @stego,
Have you got your Surf SOHO configured so that the WAP is operating in bridge mode?
Do you currently have the WAN of the SOHO connected to the LAN of the Balance 20?

Let’s start by simplify this for you so you do not need to be setting up routing tables on the SOHO.

As you are using your SOHO as a WAP, do this (high-level guide):

  • disable all DHCP on the SOHO on all VLANs giving those VLANs a Static IP for the SOHO.
  • assign the required VLAN(s) to the required SSID(s).
  • connect only one of the LANs (not WANs) of the SOHO to one of the LANs of the Balance 20 (should have matching VLANs).
  • Check required VLANs on Balance 20 each have a static IP (different from the SOHO).
  • Check that DHCP is running on the Balance 20 for the VLANs servicing the SSIDs
  • leave the WAN of the SOHO disconnected (forever).

The principles are the same here for the SOHO as if you were reusing any other combined consumer router with a built-in WAP, you disable everything on the router that you are salvaging as a WAP to do with routing and make the connection LAN to LAN ignoring the salvaged devices WAN(s).

Happy to Help,
Marcus :slight_smile:

3 Likes

Thanks @mldowling!

I’ve pretty much done what you listed already, with the exception of reserving the VLAN IPs for the SOHO on the B20. I have used an IP outside my DHCP pool for each vlan, but haven’t actually reserved them on the B20.

I did reserve the mainLan IP of the SOHO on the B20 however:

Here are the networks i have defined on the B20:

And the SOHO:

SOHO port settngs: (Port 1 connected to B20 on port 4)

B20 port settings:

My HT receiver is connected to Port 1 on the B20 and is getting an IP on the IoTVLAN21 network.

Here’s how I set my network up: IOT (Internet of Things) security with Peplink

Yeah I was trying to avoid having inter vlan enabled. This is what I essentially did with Pihole to enable it on my vlans from my mainLAN. (Deny all except dns traffic)

Your article mentions Apple protocol. Didn’t know that was an option, or you meant you listed out all the Apple protocols separately?

Hi @mldowling,

Quick question, turning my SOHO into AP also seems to bypass/ignore any firewall access rules and content blocking… to be expected as these rules are applied for anything going through the WAN interface.

I admit i was a little disappointed that the B20 doesnt have content blocking categories like the SOHO does. Not sure why, but I figured the Balance line would have more features than the SOHO.

Hi @TK_Liew,

Anything else I should be looking at? Or possible the fact I’m using a SOHO as an AP could be causing an issue?

Curious if latest firmware 8.1 is having issues with Bonjour Forwarding.

Seems there might be an issue with the SOHO detecting connected VLAN clients…

Capture

If my vlan clients aren’t appearing on the SOHO, could explain why ios devices can’t connect via AirPlay?

I haven’t been able to get it to work on Balance One, and it worked fine on 8.0.

Ah so perhaps an issue with firmware.

Sadly I returned my B20 as factory resets were no longer working and ended up in solid red status light.

I couldn’t bring it back online for support to troubleshoot via remote assistance

I had sent in a diagnostics report of a failed airplay connection

@stego, sorry to hear that of the status for your Balance 20. You may need to open a ticket to proceed RMA if it still under warranty.

I suspect your problem is related to the multicast communication, not Bonjour Forwarding. Try to enable IGMP Snooping in SOHO’s SSID as below to confirm it helps if you have a replacement Balance router for the Balance 20.

2 Likes