Blocking domains by vlan? (Surf SOHO)

Is there an easy way to block a domain for a certain vlan? I have a vlan set up for each of my kids and the ability to restrict access to certain domains by child would be nice. I can see how to do it for the entire network, but I have not found how to do it vlan by vlan.


1 Like

Hi @Coronach, you can create firewall access rules to block outbound traffic for individual IP’s or subnets to specific domains. Just navigate to advanced tab firewall access rules section and create new outbound firewall rule with the following configuration:
Rule Name: Example,
Enable: Always on,
Protocol: Any,
Source: Set single address or network (With network option you can specify your created VLAN subnet),
Destination: Domain Name, set your wanted to block domain,
Action: Deny,
Event Logging: you can enable or leave this option disabled.
I hope this helps.

Dragging this back to the top.

I found the simple solution (content blocking) that allowed me to apply this to the whole network, and used that for a while. Now, however, I need the additional flexibility of blocking a particular service (Youtube) for a single vlan or wireless network (not the same thing, I know, but it would be a distinction wthout a difference as the user only accesses the internet wirelessly). I tried using your solution above and I could not get it to work. I recognize that I’m probably doing something wrong, but I don’t know what it is. When I get home, I can try to look at exactly wat I did.


For youtube you will need quite a few rules, but even phone app’s will not show any youtube videos, it will only try to load them. You will have to block these destinations/domain names:
All of the specified domains will have to be blocked in order for your network clients to not see any youtube videos. Please let me know if blocking these domains helped to achieve your goal.

THAT was what I was probably doing wrong, I didn’t list enough domains, I just listed And, each domain will need a separate rule, correct? Sorry, I’m away from the router so I can’t see the interface to create rules.