Band Reporting Absent

I have heard that there is a bug but I want to confirm here.

I have the Max Transit Duo with Verizon sim and AT&T sim.

In WAN Details, the AT&T connection always reports the band/s used.

The Verizon connection, when in LTE-A, never reports the bands - it is absent. It reports frequencies but no bands. In LTE (no aggregation) mode, the band is reported.

If this is a bug, when will it be fixed please?



Please open a support ticket and Support Team can help to check whether this is a bug.

1 Like

Ticket #20030434

I opened this ticket. The reply from Cellular Team Engineers (per Damni) was that my Verizon was successfully connected.

I didn’t ask if it was connected. I know it’s connected.

The ticket says that the Band numbers don’t display for Verizon - only the signal metrics. It is REALLY hard to tune bands with the Custom feature when you can’t see what they are. It was only shear luck that I determined that, although Band 13 is the strongest and the band selected by default, it is also the slowest - I gained 3X the bandwidth by eliminating Band 13 from the pool of available Verizon bands. They should display, just like the AT&T bands. This is a bug I think.

Please follow up. Thanks.

1 Like

@sitloongs Still no reply from support.

Checked the ticket and Support team replied. It’s a display issue via WebAdmin page and will be fix for firmware 8.1.0.

1 Like

When can we expect firmware 8.1.0?

How can I determine the bands for Verizon, even with the bug? Tech support was able to tell me what bands it was using so I know that there’s a way. Please tell me.

Do you know how to see the Verizon bands when they don’t display on the dashboard?

Hi Joelbean,

normally you can see it in InControl.

Best wishes

InControl also says band unknown. Thanks.

Hello @joelbean,
Within InControl2 to, navigate to the device dashboard

On the right-hand side will be the connection status for each WAN type
Click on the blue “Details” for the cellular connection

Look for the text “Network Band”. If you have an LTEA connection or better, then there will be multiples of the Network Band visible.

You can also see the historical changes of this under the reports menu in “WAN Quality Reports”.

Happy to Help,
Marcus :slight_smile:

It doesn’t show a band for Verizon. Still…

Hello @joelbean,
As I’m based in Australia, one of the Peplink Community in America may be able to check for you.

Also, @sitloongs did mention that there is an issue that will be sorted with a future update. Keep working through your support ticket, Peplink may be able to give you a beta release in the near future to resolve the issue.

Stuff like this happens with all vendors as carriers/ISP change their networks at their own digression (interprets the standards in their own way), this affects the way all mobile/cellular devices operate and is especially noticeable on commercial equipment where we have access to this additional in-depth information. Working with Peplink we found a recent change to the Telstra network here in Australia was affecting the way the Cat-18 chipsets behaved. Peplink worked with the chipset manufacture to deploy a patch, these patches/updates normally get made available in the future major firmware updates.
Happy to Help,
Marcus :slight_smile:

1 Like


If the cellular module connected to Band 66 , then the WebAdmin page will shown no bands info for the connection. This is the bug reported for firmware 8.0.2 and will be fixed for coming firmware 8.1.0.

You can simply conclude as below:

  • If no bands info show for the cellular connection then the cellular module is connected to bands 66.

If you check on the IC2 WAN quality report:

This shown that the module is connecting to Band 66.

Base on the screenshot given for your device, Carrier Aggregration (LTEA) is both connected at band 66. Hope this explained your concerns.

1 Like

Band 66 is popping up more and more these days and I believe we are in a transition phase on how it is reported as modem firmware and base station firmware evolves. This is the same thing as the Band 17 to Band 12 thing a few years back.

Band 66 encompasses the AWS-3 spectrum which also includes the AWS-1 spectrum, otherwise known as Band 4. There are defined Blocks for each spectrum but the point is that Band 66 covers all of them and it is just easier to report Band 66 rather than just a subset of Band 66.

In other words, it is entirely possible that you are actually connecting to traditional Band 4 but your base station (eNodeB) has been updated to report it as Band 66.

Anyways, the good news is that you tripled your bandwidth!


1 Like

Thanks Everyone. Yes, I removed band 66 from the pool in custom settings and, indeed, the bands show up for Verizon. When I include band 66, bands don’t report. And yes, my performance is much better with band 66 in the pool.

Also, I don’t allow band 13 with Verizon - with it available, it is ALWAYS selected and the performance is hideous. Now my question is… How/why does the Max Transit select the under-performer? How can I get AUTO to be more correct in selecting/connecting bands? Most users will think that its selection process is efficient, and may not discover that removing a band will give better performance. Big loss.

Thanks again!

1 Like

Unfortunately cell modems look at signal strength and quality to select channels. They can’t see the throughput of the channel. They can take into account theoretical throughout(channel width), but they won’t take into account real world throughput. So often I see my modems using strong signals that suck for throughput. I’ve found 2 solutions.

  1. Custom band selection and lock it to a particular set of channels.

  2. buy a Cat 18 modem so you can connect to 5 channels at once lol :slight_smile:


If there was a dual-sim solution with cat18, I would consider it. I just invested in my Max Transit Duo Cat12 so I’m not chomping at the bit for better, yet.