Balance One Core unable to access AP firmware packs

From within a Balance One Core dashboard, I can see the availability of AP firmware pack 1171 (release date 2020-02-17), but clicking download just results in an ever-spinning progress indicator. Is this my unique issue or is the firmware pack server down?


I just do a quick check with my MFA device and it’s working fine.

Can you try to delete the older one and try to download the latest one again ?

1 Like

I had that issue back on firmware 8.0 on a balance 20, I just tried multiple times and eventually it went through. Then the 8.0.2 release notes had a few bug fixes specific to AP pack firmwares, so I assumed the issue is gone on the new firmware. Are you on the latest firmware?

1 Like

I am on the latest firmware:

And I see the firmware pack is available:

But clicking the download link just shows a spinner that never stops:

What is the target server address? I’d like to run a traceroute. Thanks.

1 Like


Please open a ticket for this to allow support team to check on this.

1 Like

Having the same issue here with a Balance One. At the most recent firmware level on the Balance One. Can see 1171 in the list, but clicking on it results in a never ending spinning progress indicator. I’ve tried this off and on for a few weeks now.

Was there an issue identified and resolved with the ticket that was opened?


No resolution, but they eventually acknowledged it’s a known issue and provided a temporary workaround.

They first sent me a direct like to the firmware pack, so I downloaded it and I attempted to load manually, with only one other firmware pack in the Balance - the pack currently being used by the downstream APs. And no dice…but at least this time the router provided an error message:

Which makes zero sense since I only had one pack loaded.

They later acknowledged it’s a known issue that may be fixed in router firmware 8.1.1… and provided instructions for a workaround, but it involves deleting the current firmware pack (1170), which provides no easy path for rollback, so I’m not doing that since this firmware doesn’t really provide any useful changes for my downstream AP One Es as I understand it.

Thus, the ticket remains open.

From the ticket:

That’s a known issue regarding pack storage. Possibly will be fixed in 8.1.1 GA.

As of now, find the attached screenshots and do the steps for all the managed APs. Scuba, you may delete the existing firmware pack (1170) and upload the new firmware pack (1171). Then he can re-manage all the APs with firmware pack 1171.


Thanks for the info and potential solution. Going to wait here too. Mainly running with the Rugged AP and not critical to update at this time (I don’t believe I saw anything useful in the 1171 firmware pack for the Ruggeds).