Balance ONE and AP ONE Ent - WiFi Handoff Issue

Hello All,

I have a balance one AP Controller along with several AP One Enterprise. My issue here is that while moving on the yacht from cabin to cabin and while there is wifi coverage my iphone will not connect to the AP with the strongest signal but rather keep a connection to the AP with the the lower strength signal and at some point eventually will move to the AP with the better signal.

As this affects VOIP calls etc. with the disconnects and while i have tried to allow only e.g 5G band with 80MHZ width is there something else i can check?


  1. Make sure Fast Transition is turned under under the SSID configuration
  2. The iPhone should move when the signal is under -70 and there is something better to move to. However, I’ve personally noticed this only works while using the phone. If the phone screen is dark and you move the phone to a different room and set it down, it will stay attached to the farther AP until someone interacts with it - Some sort of power saving feature I guess.

Thanks Metz.

The way we test is by using two iphones connected via wifi on the same SSID and starting a facetime. One remains still while the other is moving. On certain points and while there is coverage the signal is getting completely lost.

Forgot to mention that on balance i have enabled on the testing SSID both 2.4Ghz at 20Mhz with Auto channel selection and 5Ghz at 40Mhz again with Auto channel selection. Power is both MAX with boost enabled.

Would also make any difference at all if i configure Client Signal strength Threshold with a value of 30 or 40?

TBH i thought that with Peplink seamless roaming would be easier…

Thanks again.

  1. I wouldn’t use Auto Channel selection, it doesn’t work well in my experience … better to set them manually if you can.
  2. use 20mhz channels if you are happy with 90-100mbps … use 20/40 for 100-200mbps. When I used 40 rather than 20/40, the iPhone didn’t appear to like that very much, I can’t tell you why.
  3. power should be set so that the AP can reach the same distance as the phone…. For me … “high“ power achieves this goal. If you set the AP to boost, it could be that the phone can hear the AP 400 feet away, but the AP can no longer hear the phone, so it drops without choosing the next AP. Less power from the AP is better in that case.
  4. setting a signal threshold causes the AP to kick the client off and make it go to the next AP… generally we would rather the phone choose when to change APs, rather than the AP kicking him off the WiFi and forcing the phone to recover.

hope that helps.

1 Like