Balance e580 can't access menu

I’m trying to do a factory reset on a Balance e580 but I can’t even access the menu. When it first booted, I got into the menu but I couldn’t move the arrows, then I tried again and I’m stuck at the screen that says “Balance 580 v8.0” and it won’t let me access the menu. Is it a lost cause or can I do something else?

Hi @vargsyster,

Welcome to the forum. When connected directly to the router LAN port do you get IP address from it ? If you don’t, you can try setting static IP address to check if you would be able to reach its UI. From your description it’s possible that only the screen stopped working.

We got it from a client and they just wrote “broken” on it, I can’t access the web interface either.

Any signs of life on the serial console?

Haven’t tried the console port. I just wanted to do a hard reset but can’t get past the first message on the led screen. We don’t have the ip and password for the web interface. It’s not default.

@vargsyster, please open up a ticket:
I will try to assist with this issue.

Created ticket #21020860