Balance 580, VPNs, and SMB Cisco


#1

Good evening,

I am turning desperate with the Balance 580.

Here is our setup :

3 DSLs, 1SDSL, 14G Backup device

Lan is supposed to be like this :
172.* : admin lan, holds the Peplink Balance and the Cisco SMB Switch interfaces
10.0.1.* : Main VLAN with workstations
10.10.10.* : Other VLAN that has to stay separated due to multicast activity

Cisco switches are SG500-52, not stacked, with layer 3 active.

I activated the “Advanced Lan” in the Peplink options to be able to “play” with VLANs
I have one main LAN corresponding to 172.1.1.0 / 255.255.255.0 / Peplink is on 172.1.1.1

–> I would like to have the Peplink distributing the IP Addresses of VLAN machines to avoid using the Cisco’s DHCP (more complex to input things)

For that i m trying to create a second LAN but Peplink refuses to save it. i tried creating it with 10.0.1.0 10.0.1.1 10.0.1.254 in fact i dont even know what is supposed to be filled in there.
SAVE button does not do anything, LAN is not added whatever the values i insert.

I made ONE successful configuration where i could add a second LAN named 172.1.2.* where i could setup some DHCP IP assignment based on mac adress. Adding the route back from the peplink to the cisco switch is done. things work not “too” bad except that the Peplink does not send the correct Gateway to the 172.1.2.* IP Pool, computers are given 172.1.1.1 gateway. They should use the virtual 172.1.2.254 Cisco Gateway.

I cannot see where i can force the gateway distributed by the DHCP of this specific LAN

In fact i m missing quite a lot of answers concering problems that seem to be “level 1 easy task section” category.

configuring the Cisco DHCP works good. The add host interface is just a pain and the final user will never agree to use it to add future IP on his new hosts.

I would really prefer to use the Peplink DHCP for that, but i need to be able to specify the correct gateway, and also, to be able to create a “VLAN” with the IP i want, and not one “close to the original one”

Thanks a lot for any help and suggestion, i’m kind of “new to this”, please be patient, i m a fast learner.

PS : i have 3 days to make this happen.

Edit :

I didnt realize firmware 6.1.2 was out last friday… and autocheck function did return “no new firmware”. can be explained by the fact i have a HW2 PEP580.
anyway, with this firmware, adding a 10...* vlan is possible and gateway assignment through DHCP option works. that s all i needed until now. i ll comment further in this thread if i get other surprises, it could help others.


#2

Hi,

Thank you for your valuable feedback.


#3

Hello Forum and Peplink Team.

I added two DSL lines on the peplink

I cannot get the SpeedFusion to boot up

I cannot DELETE SpeedFusion Profiles (no red cross)
I cannot ADD another SpeedFusion Profile (Fields are greyed and cannot input anything)

it is the same through Incontrol

Both Devices on each VPN End are 6.1.2 firmware

can someone tell me what the … am i missing ???

I have difficulties that should NOT exist at this grade of hardware. This is an expensive routeur. Things like “Red X disappeared i cannot delete a profile” just do not match this grade of hardware.

what did i do wrong ???


#4

Hi Florent,

I guess you were configuring the SpeedFusion VPN from InControl 2.0, which the profile has been pushed into the managed devices. This will “locked” that particular SpeedFusion profile when you accessing from the device Web Admin.

You may remove the SpeedFusion settings from InControl 2.0, and manually create the SpeedFusion profile at the devices Web Admin.

Do let us know if the problem persist, then you may submit a support ticket here.

Regards,
Wei-Ming


#5

Good evening and thank you WeiLing,

i managed to reconfigure the speedfusion by disabling the Incontrol Settings.

I ll get back on Incontrol once the setup is good and functionnal.
I dont understand why incontrol wont allow me to modify speedfusion settings locally and on incontrol website.

i ll check that later.


#6

Sure, Florent. Let us know if you need further assistance. :slight_smile:


#7

Hello everybody, Good Evening…

I have a performance problem now on the setup, i m going to make multiple tests to see how i can optimize things, but if you have ideas, i m all ears.

3 DSL lines, asymetric, with roughly 9500kbit/s down and 1024 up on each line
Each line is on a different ISP
average ping is 20 to 30ms on each of them.

All “DSL Boxes” are setup as DHCP router, and assign an ip to WAN 1, 2, 3 on the peplink.

Result so far :

One line always get Drop Rate between 50 and 100. Average Ping goes in the 80-100ms. Total Bandwith is 20-22Mbit/s down, 1.6-2Mbit/s up
And the surfing experience feels a bit like browsing on an old telephone in Edge Mode…

If i remove 1 line things get slightly better, and it could be just a mind trick. With 2 DSL lines, one gets drop rate, and the VPN carries only 2 third of the bandwith capacity

I m going to try playing with MTU (autodetect on each WAN but i ll try manual settings, to see. French ISPs have an obscure history in term of MTU…)
I ll try configuring the DSL Boxes in “DMZ mode” sending all traffic directly to the peplink WAN interface
I can configure one DSL Box in Bridge Mode, i ll try that scenario too, with 1 Bridge 1 DHCP 1 line Off, to check if i still get drop rate on the second DSL Line

etc

will keep you informed. any idea is good to read, dont hesitate to suggest things.

I have 60 hours :slight_smile:

Edit 1 : (second try, just lost my post, forum asking to auth again :frowning: )
One Line had a bad MTU. I did set all lines to smallest MTU value of all three, 1440.
I still get drop rate. if i remove the line having drop rate, another one will then get drop rate.
Browsing the web is better and smoother.
This is the graph of a single download. doesnt look great.



#8

Hi Florent,

Please open ticket here. Please turn on Remote Assistance as well.