Balance 580 BGP Routing used ip public on dmz lan

Hi,

I have a case about BGP Routing in a peplink, first my customer have cisco router and used bgp routing to expose ip public on office, and he need to used function health and load balance wan on peplink. So we repelacement router cisco with peplink.
After i configure bgp routing like this.
############################################
interface GigabitEthernet0/0/0
description * Connect to DMZ-Public-Switch *
ip address 103.197.89.254 255.255.255.0
negotiation auto
cdp enable
!
interface GigabitEthernet0/0/1
description * Connect to ISP Biznet *
ip address 202.169.34.154 255.255.255.252
ip access-group 101 in
shutdown
negotiation auto
cdp enable
!
interface GigabitEthernet0/0/2
description * Connect to ISP Fibernet *
ip address 116.197.135.194 255.255.255.252
ip access-group 101 in
negotiation auto
!
interface GigabitEthernet0/0/3
description * Connect to ISP iForte *
ip address 182.16.160.126 255.255.255.252
ip access-group 101 in
negotiation auto
!
router bgp 134621
bgp router-id 1.1.1.1
bgp log-neighbor-changes
neighbor 116.197.135.193 remote-as 58369
neighbor 182.16.160.125 remote-as 17995
neighbor 202.169.34.153 remote-as 17451
!
address-family ipv4
network 103.197.89.0 mask 255.255.255.0
neighbor 116.197.135.193 activate
neighbor 182.16.160.125 activate
neighbor 202.169.34.153 activate
neighbor 202.169.34.153 weight 100
exit-address-family
!
ip forward-protocol nd
!
#########################################
On behind cisco router 103.197.89.254 have a fortinet 103.197.89.16,
and behind fortinet many server have ip public like 103.197.89.151 103.197.89.152 , this a server application, function fortinet just distribute accsess to can call from internet to go server my client on this case is 103.197.89.151 103.197.89.152 .
We already to set lan on 103.197.89.254 and set bgp like config router cisco, and we also already to advertising ip network lan 103.197.89.0/24. After that we just ping on internet 103.197.89.254, we goal is any have ip 103.197.89.0 reach on internet, because we need also provide ip 103.197.89.16 to access to go can call from internet.