Balance 30 LTE can't upgrade past FW 6.1.0


#1

My Balance 30 LTE firmware 6.1.0 refuses to upgrade to any newer firmware. It’s out of Warranty, but I thought I still had access to 6.x firmware upgrades (?).

It starts to upgrade, but then goes into limbo and needs a reboot. I’ve tried different browsers, different computers, mac/pc, http/https, manual and auto, firmware slot 1 and 2. Tried 6.1.2, 6.3.3 and various others in between.

When uploading manually using Chrome, it locks up at 65% upload.

Am I SOL or is there a cure?


#2

Hi,

Can you please try to upgrade the B30LTE using the following step:

  1. Update firmware with the following update - -Note: the device will reboot after upgrade.

http://download.peplink.com/firmware/plb30/fw-b20_30-6.1.1-build2530.bin ( May take up to 30Minutes )

  1. Update firmware with the finishing update -

http://download.peplink.com/firmware/plb30/fw-b20_30-6.3.3-build3231.bin

Do keep us posted for the upgrade status.

Thank You


#3

That worked beautifully!

FWIW, I would have tried installing 6.1.1 first, but it isn’t listed in the firmware archive: http://www.peplink.com/support/downloads/archive/ .

I’m happy to report this fix also restored my ability to use the Peplink Router Utility ios app, which hadn’t been working.

Thanks a million!


#4

:up::up::up: