Balance 30 - Latest Firmware 5.4.7 - DNS


#1

I have been using the service proxying / forwarding of DNS without caching. I have had this configuration for nearly 6 months with previous versions. However, since the recent upgrade I seem to be having issues at random. Every few days I cannot get any response for DNS lookups. I have tried it manually to the router, tried multiple DNS sources (ie. my personal DNS servers, OpenDNS, Google, and Verizon (4.2.2.x) - yet the issue still seems to come back randomly. It is almost like the router becomes overloaded.

When this occurs I cannot reach it on it’s internal IP as well (Peplink).

In the end, I have to reboot the Peplink and it begins responding to DNS requests again. I am going to turn off the service proxying of DNS to see if that’s causing it or if something else on the network itself may be hitting it with too much data (broadcast traffic or something else) and effecting DoSing the router.

Is there a method of actually getting some netstat / tcpdump data from the router? I had read somewhere you can SSH into these. I haven’t attempted it as of yet but outside of configuring remote syslog/SNMP - is there normal log files on the system itself? Would dmesg just work or checking something like /var/log/messages, etc? I guess instead of asking all of these questions I could just log in and check around but I wanted to see what the best method of retrieval would be so I can provide some feedback to Peplink regarding the apparent livelock’s.

FYI: The majority of my traffic internal to the network goes back through a Netgear R6300 connected to the Peplink 30 - it itself has 3 x Cable modem connections feeding it. I have verified via direct connection to the Peplink - the DNS issue exists even not going through the Netgear. I have seen this issue, however, in the past on my previous every day routers due to the sheer amount of broadcast traffic either coming from the cable modems or ** a Samsung Verizon network extender I have. This network extender seems to slam whatever it’s connected to with arp requests constantly. No apparent reason why but for now, I have connected it direct to the Netgear - in a hope to slow the trash traffic hitting the Peplink.

These are really the only oddities within the network. There is no bittorrent traffic or anything like that - no heavy uPnP other than the Samsung Network Extender and no opened NAT ports or any DMZ addresses.

Last Note: I have a 10.0.0.x address scheme on the Netgear network DHCP. I have a 192.168.1.x subnet configured on the Peplink. The purpose of the segmentation is to ensure there is no cross traffic other than the single static route from the Netgear to the Peplink. All clients are DHCP to the netgear and look to it for DNS. It simply looks to the Peplink (since it’s directly connected) and like I say - there has never been an issue until the last 2 weeks.

Thanks,
Kevin


#2

Hey Kevin, firmware version 5.4.9 may resolve this issue you are having. It is scheduled for public release on Wednesday, so please download it from our site and upgrade to this version and let us know the results.

If it persists, we will need you to download a diagnostic report and submit a support ticket in our system so we can take a deeper look.