Balance 20X - Google Fi LTE Issue

Hello,

I am trying to bring up the LTE links with a google fi card but it is not detecting a SIM card and cycles on “resetting” i occasionally see it move to “obtaining IP address” but it never moves past that stage. The same SIM works fine in my MAX BR1 mini with the settings below and i am using the same “Sure call” antenna on both.

Any ideas on how i can troubleshoot this further? Are their any differences between the LTE radios on each and why is “Generic” missing as an option on the BR20. I only see Auto, ATT, Verizon, and Tmobile

4G-WAN Standby (Google Fi) 162.189.28.239 LTE-AClose
WAN Type Cellular
IP Address 162.189.28.239
IP Subnet 255.255.255.254
DNS Servers 10.177.0.34, 10.177.0.210
Routing Mode NAT
MTU 1428
SIM Card A IMSI310260974046964 (In Use)
SIM Card A ICCID8901260971140469642 (In Use)
SIM Card A MTN18622129832 (In Use)
SIM Card B IMSI-
SIM Card B ICCID-
SIM Card B MTN-
MEID HEX 35907206169756
MEID DEC 089865882201480534
IMEI 359072061697567
Carrier Google Fi
Carrier Settings Custom
APN h2g2
Username (Empty)
Password (Empty)
Cell ID 40708
Network LTE
Network Band LTE Band 12 (700 MHz)
Signal Strength RSRP: -115 dBmRSSI: -86 dBm
Signal Quality RSRQ: -17 dBSINR: -4.6 dB
Secondary Band LTE Band 4 (AWS 1700/2100 MHz)
Signal Strength RSRP: -129 dBmRSSI: -103 dBm
Signal Quality RSRQ: -16 dBSINR: -8 dB
Health Check Method SmartCheck

I am experiencing a similar “obtaining IP address” challenge with ATT prepaid SIM with Transit CAT18 modem. In the same location a Verizon SIM is getting past “obtaining IP address” and working fine.