Balance 20X Cellular Status stuck in connecting

Testing a Balance 20X, when powered up cellular shows no IP address and status is connecting. The sim works in MoFi 4500, Netgear LB1120, and Netgear LAX20. APN is correct. Firmware is up to date.

Anyone have any thoughts or suggestions?

Hi @Matt_Ramirez . Can you tell us what country you are in and which carrier you are having issues with? And, I wonder if your have tried another SIM, perhaps from a different carrier? Your first steps at troubleshooting are good – double-checking APN and using the SIM in another device.

1 Like


I have not tried another carrier yet.

What setting are you using for APN?

1 Like


Not what setting are you using - what value for the APN was what Rick was asking…

It should be something like:


1 Like

We are on the IoT Wholesale platform so our APN is iot.tmowholesale. The device is on the list of certified devices for that platform. We did some tests rolling back to previous firmware as I saw in the forums that a few folks had the same issue but updated to 8.1.1 which resolved the issue. This did not work for this device.

Has anyone encountered a Peplink device that whose TAC was blocked on the network?

OK, the APN @erickufrin gave you is generally correct for TMO. However, we have many TMO M2M SIMs in use and the APN for those it’s different. For those, it’s m2mglobal . Might be time to submit a ticket.

Thank you @Rick-DC and @erickufrin for all your insight. The issue turned out to be bad antennae. It is now resolved.

1 Like

OK. Just out of curiosity … How did you find it? What steps did you take? I’m always curious as to how folks, particularly those who don’t do this every day, approach troubleshooting.