Balance 20X and Starlink - drops connection every few seconds

Hi All,

I just connected my Starlink to my Balance 20X via ethernet today and have had some inconsistent results. It will work for a minute or two, but then the starlink connection drops. It will come back a few seconds later.

There are no obstructions for Starlink, and other devices that are connected to Starlink via wifi remain undisturbed.

I am trying to set this up so I have failover for work applications on two devices by using Starlink and fixed wireless, but at the moment I cant get any stability.

Any help is appreciated!

Usually that means the Balance is doing exactly what it is supposed to be doing. If you have no other WAN in use I’d disable the health checks. If you have a 2nd WAN I’d set the health checks to ping and set targets as two different owners – e.g., and

Starlink: You may still have short duration drop-outs even though there are no obstructions.

I might add that SPeedFusion is your friend in situations such as this. A license for SFC is inexpensive and can be obtained quickly. (If interested - send me a PM and I can send you back a link.)

Finally, what does the log show?

Interestingly, I also just got my Starlink ethernet adapter yesterday and connected to my balance 20x wan port and experiencing the same thing. Other devices connected directly to starlink will work fine while the balance 20x shows down due to failing health checks. I’ve tried both ping and dns lookup for health tests.

It sounds like we both need to enable bypass of the starlink wifi router in the app. I haven’t done it yet but another person on here said they needed to do that on their V2 system and worked fine after that.

I think you are right. I am going to give it a shot this evening. Let me know if that fixes it for you.

Circling back on this. I finally got around to enabling ‘bypass starlink router’ in the Starlink app and now the Ethernet connection is rock solid on the Peplink Balance 20x.

1 Like