Balance 20 - MTU keeps changing


#1

I have a Balance 20 running 5.4.9, it doesn’t seem to matter if the MTU is manually set or auto. On the computers onsite I run a ping command with the -l “packet size” -f switches and the MTU keeps changing from between 1200-1350. I have talked to the ISP and their fiber is set manually to 2000. I have an IPSEC VPN setup to the main site and I have tested going through that and direct to the internet, it happens both directions. This wouldn’t be a problem except it is causing Outlook to drop connection to the Exchange server at the main site. Please let me know if you have any thoughts. Also this issue was happening in version 5.4.7 and seems to have gotten worse after upgrading to 5.4.9.


#2

Hi Joe- You may want to manually set your MTU and then set a custom MSS. I googled this for a bit and I believe you would want to set it 40 bytes lower than the MTU value.

I’m no expert in this area, maybe someone else has an idea?


#3

The problem is not solved by setting the MTU manually since it keeps changing, I can set it one day and then the next it can be lower than my previous manual setting.


#4

Hi Joe- the Balance will not change the MTU value randomly on its own. It seems like their is something wrong with the ISP’s connection.

We can confirm that and take a closer look if you start a support ticket in our system:
http://cs.peplink.com/contact/support/