Balance 20 Full Duplex not working


#1

I’ve installed a Balance 20 at a customers site who has Cogent as the ISP. Cogent requires the connection to be 100 full duplex to meet their SLA. The Balance 20 is set to 100 Full but will not pass traffic when Cogent sets their port to 100 Full. They have to be on Auto for this to work.

It works just fine if I set a laptop to 100 Full and connect it directly to Cogent’s port.

I’ve just updated the firmware to v6.2.0. I’ve also tried different patch cables. Tech support at the dealer is now saying to try MAC spoofing. It’s a long ride down there and I’d like something a little more substantial to try. Otherwise I’m going to have to replace it with a Sonicwall.

Has anyone seen this behavior?


#2

Hi,

Please disable Advertise Speed on WAN interface and try again. Do let me know the result.


#3

I’m afraid I’ve already tried that. No luck.


#4

I would also check the support.cgi page to ensure that they are negotiating properly once you hard set it to 100Mb FD. Otherwise, if you have a un-managed switch handy to put in between to Balance/Cogent to help eliminate HW incompatible/port negotiation issues.

To get to the support.cgi page:
http://”IP of your device”/cgi-bin/MANGA/support.cgi


#5

It is saying that it’s at 100 FD.

The dumb switch only helped a little. As soon as Cogent switched from auto to 100 FD the throughput dropped from 90Mb/s to 15. and they started seeing errors and I was seeing dropped packets. Their router said that the switch was still in auto mode.

One thing the switch proved was that the problem isn’t with the Peplink. Unfortunately, the customer doesn’t care about that. So the Peplink goes back and a Sonicwall goes in.


#6

Also, after doing a little research. It is rare and I have only seen this being done with the ISP Cogent. It appears that there router at times will “blacklist” mac-address (Balance WAN MAC) and this may be the issue.

Calling Cogent they may be able to clear this up, otherwise a previous fix is to go to Network>WAN>Cogent WAN>Physical Interface Settings: Choose custom for MAC Address Clone. With the PC that was directly connected to the Cogent link and was able to get out to the internet without issue, input the MAC address of the PC here to see if this fixes the issue as it was a fix in a previous case.