Balance 20 - Failing DNS Tests


#1

Hi! I have a rather basic set-up:

3 workstations connected to a Balance 20 on a LAN connected through WAN 1 to Xfinity service; and through WAN 2 to Verizon 4GLte via a wireless modem. The Xfinity/WAN 1 is the specified as the priority connection.

After running Setup Wizard for both WAN ports, WAN one gives me an IP Address of 10.0.0.7 and a Status: Green and Connected; while WAN 2 shows IP Address: (non) and Status: Cold Standby. But, when I pull the cable to the Xfinity, the Verizon service does not kick in; and I get an error message: DNS Tests Failed. Before, there was a warning that DNS Healthchecks failed; to which I ran the traps on the forum looking for possible fixes, including checking the second box: “Include public DNS Servers”; and increasing the Health Check Retries to 5. This did not work.

Today, by Xfinity dropped out for most of the day; and I had hoped/planned that the Verizon service would just step right in; but it did not. In fact, I had to rip out the connections from the Balance 20 and manually put them on the Verizon modem. The service was there; and my work went uninterrupted. Now, I’m trying to set up this Fail-Back so it actually works; but to no avail. No matter I how I approach:

What is wrong here in this basic configuration? Why can’t the Peplink see the WAN 2 DNS?

Thanks! RodeoTrader.


#2

Hi RodeoTrader,

Please configure WAN2 as Always-on (Network > WAN > WAN2 > Connection Settings > Connection Type > Always-on). Then provide the screen shot for Dashboard, WAN2. I can provide better advice with the requested info.


#3

Thanks peplink Team.

I turned WAN 2 to Always On. and attach the Dashboard screenshots after. Thanks for the help!

RodeoTrader.




#4

The problem is because your LAN interface and the WAN2 interface are in the exact same subnet, they both cannot be 192.168.1.x so you need to change one of them. The easiest way would be to change your LAN IP scheme to 192.168.2.1 for example…


#5

I presume I need to change the LAN address in 2 places? BOTH - in the Xfinity Router itself; and then via the Network settings in the Peplink?

What is option 2 if I don’t want to change the current LAN address? Thanks?!

RodeoTrader


#6

Only one of the interfaces needs to change to be unique from the other. Option 2 would be to put your modem into bridged mode and it will pass the public IP address to the Peplink.


#7

When I changed the LAN settings in the peplink to the unique address you suggested; I completely lost my internet connection - this is why I ask. I reset the peplink to factory restore and ran the wizard to get to the exact same place where we were earlier tonight.

Not to be too needy, but can you give me a step by step to change it in the peplink so it will work and I won’t lose my existing connection? Thank You!


#8

You lost your connection because your PC and other devices are still holding on to the old DHCP issued IP address. Simply unplug and replug the cable or just restart the devices so they grab the new address.


#9

It works! Great! Thanks!

Now - a question: when I unplug the WAN 1 internet, the WAN 2 wireless in Cold State turns on and the connection is restored. Plug back in WAN 1; and WAN 2 goes into Cold Standby. Just what we wanted.

Question/however - it does take a couple of seconds for the connection to be made; although I thought it would Fail-Back within a second, etc. if it is constantly polling that connection. Is there a way I can ensure it is as fast as possible on the switch over? I am trading financial data streams and even a small drop in the feed can mess up the models/processing. Am thankful for the Failback for sure; just wondering if we can optimize it ?

Thanks!

RodeoTrader


#10

Hi,

WAN fail-over for internet access definitely will cause internet downtime. As this include the network traffics pass-through 2 different internet connection & using the two different NATed IP address (NAT more deployment). Beside that, time taken for the trading financial application to recovered when the WAN changes also need to take consideration here.

You can fine tune the WAN health check settings to improve the fail-over time. For more information, please refer to the screenshot below:

To achieve seamless and Hot Failover you may consider to use Peplink SpeedFusion solution.

For more information, please refer to the URL below:


P/S: This is depend the SpeedFusion deployment design for the application to achieve seamless and Hot Failover.

Thank You