Balance 20 - 502 Bad Gateway After Login


#1

I have a Balance 20 which keeps throwing a 502 Bad Gateway The CGI was not CGI/1.1 compliant exception whenever I log in. The log in screen is showing normally when I first go to the <IP>.

I have tried to login to the Balance from an updated version of Chrome and Firefox (from an updated Ubuntu machine) as well as from an updated version of Mobile Firefox and Mobile Chrome from my Android.

I have tried factory resetting the router. After holding the reset for 10 seconds the Status LED flashes Red but it appears that the Balance is not rebooting after the reset is released. I have manually rebooted by unplugging and plugging back in after the Status LED flashes red and that has also not appeared to fix the 502 exception.

It appears that I’m able to log in without a problem, as I’m redirected to <IP>/cgi-bin/MANGA/index.cgi. It also appears (from what I can tell) that the router is more or less working as expected – although without being able to log into the web interface I have difficulty verifying.

I do not remember which firmware I was on, and I have not updated the firmware within the last three months. Without the web interface (and from the forums I learned that I cannot flash firmware via the USB port) so updating the firmware is currently out of the question.

Does anyone have any ideas how I can solve this issue?


#2

After you factory reset it can you confirm if the status light goes green after boot up?


#3

After factory reset the Balance is not going through a boot cycle. If I unplug and replug it then it boots and the status light goes green.


#4

I would recommend creating a support ticket here http://cs.peplink.com/contact/support/ so we can further look into the issue.