Bad IP address being assigned

When linking several devices that have been rebooted since their last router connection (24 hours ago), the SOHO (2nd gen) is assigning strange IP addresses such as Naturally they have no internet access.

Strangely, devices (laptops, phones, Echo ) that have not been rebooted have retained their 192.168.50.xx addresses and work just fine.

The lease is set to 210 days. The dashboard setting under Network–>Network Settings shows as expected. However, under Status–>Client List it shows WiFi connections of

How can I fix this?

169.254 addresses are usually auto assigned when a DHCP server could not be reached. It is known as auto-configured. it is done by the operating system on the device – not the router.

Be sure and check active sessions and see if any unusual connections are going on. Also check UPnP / NAT-PMP and see if a device is running a torrent.

Thanks, this is just a home system for two people . . . nothing unusual or “nasty” going on.

As @jmjones suggested, this would seem to be a situation where the clients can’t “see” the router. To better understand the situation I think what I’d do is reboot everything from the “internet side” inward, in sequence – modem (s), router and clients that are having issues. Wait until one device is “up” before proceeding to the next.

Alternatively, disable the wi-fi adapter/capability on each of the clients that are having and issue – and then re-enable it. It’s interesting that the “auto-configured” devices are both wi-fi, and the ethernet devices are not having a problem.

Then, can you ping from each device? Did the “auto-config’d” devices get a “real” address? Please let us know what you find – this is interesting.

1 Like

The SOHO gets its WAN feed 100% from cellular hotspots and has worked without issue for many years.

After multiple reboots of the router and the AT&T Nighthawk hotspot (leaving the router down for 30 minutes before plugging back in), it still had the same problem. On a whim, I swapped out the AT/&T Nighthawk for a Verizon 8800L hotspot, rebooted and everything was back to normal. That didn’t make sense as the Nighthawk has worked well for a long time and still worked well when not tethered to the SOHO.

I shut everything down again, brought the Nighthawk back up and tethered it to the SOHO. I then plugged the SOHO back in and everything was back to normal with the SOHO handing out legitimate IP addresses again to all devices.

As an aside, the client PCs only showed the bogus IP addresses when they were attached to the router. The network icon showed they were attached but it said “no internet”. Since the problem has resolved itself for now, I can’t try the ping. I should have tried that when I was having the problem, but I didn’t think to do that.

The really strange thing about this is that this happened “out of the blue” . . . no changes were made to either the hotspot, the router, or the effected clients. The hotspot and the router are on a timer that reboots them every night to keep the internet connection fresh.

Thank you kindly for taking the time to make suggestions. Troubleshooting problems with multiple device “layers” is stressful, and a fresh set of brain cells is always helpful.

Yea. That’s quite weird – but glad it’s working. As a “side suggestion”: At some point you may wish to consider migrating from hot spot(s) to a cellular modem. Lots of folks use wifi-as-WAN and it works well. However, we’ve found a direct connection between the modem and the SOHO works better. A bit more reliable. “Just sayin’ …” :smirk:

1 Like

I never use WiFi as WAN . . . I tether either via USB or Ethernet, depending on the hotspot. We are RVers and travel extensively and need to be able to disconnect the hotspot and take it with us.


1 Like