B20 WAN failed DNS test


#1

Our long running B20 suddenly started giving us the WAN failed DNS test. I have tried a few things to troubleshoot… I would appreciate any other things to try.

WAN1 = DSL (works fine)
WAN2 = Cable Company (problem child)
WAN3 = No connection (port is activated)

  1. Connected a laptop directly to cable modem – I can get an IP and get on the internet
  2. Ran different long from cable modem to WAN2, got WAN failed DNS test
  3. Configured WAN3 with the WAN2 settings, cloned WAN2 MAC to WAN3 and moved the cable connection to it, WAN failed DNS test
  4. Disabled Health Check – status is Connected but no internet activity
  5. The mandatory router reboot (had to wait for this one)

image


#2

Can you try to set helth check method as Ping and in host 1 and host 2 set 8.8.8.8 , 8.8.4.4 ?


#3

It failed the PING test. I have to check with the cable company again to make sure that nothing has changed on their end.


#4

the ping failed also with google dns ?


#5

Yes, it did.


#6

Have you tried connecting the cable modem direct to a pc and confirm it is actually working as you expect?


#7

Yes, that was my first test. I plugged in a laptop to the modem – it got an IP and I was able to connect to the internet.

Edit: Just updating that this might be a problem on the ISP end. Will report back if confirmed.


#8

Hi there!.

This is happening suddenly to me too… I have a peplink balance 210 with firmware 7.1.2 build 3575. I created a support ticket #791191 a few weeks ago but no answer yet.

Best regards,

Reginaldo Bray


#9

This is now resolved. The ISP did an update on their end that broke my connection. We are back in business.

Thanks!