B20 UI & PepVPN unresponsive after WAN change


#1

This morning I tested one of our Balance 20 devices by first disconnecting WAN 1 (Comcast cable internet). All traffic appeared to be redirected to WAN 2 (DSL connected via a wi-fi client) – good. Then I simulated a failure of WAN 2 and expected traffic to be transferred to the AT&T 4G card plugged into the USB connector. All worked perfectly – as expected. Well, all was good until the next step …

I then reconnected WAN 1 and WAN 2 by plugging the ethernet cables back in within a few seconds of each other. Now, the B20 appears to be working with two critical exceptions:
(1) The UI is totally unresponsive. The last screen I saw, captured and shown below, shows CPU at 100% and all three WANs connected. I can’t see the UI and Firefox shows the web interface as “connecting.” There is also no connection via the iOS client.
(2) PepVPN has not started.

While I’d LOVE to submit a ticket on this, there is no way I can invite remote assistance or to save a diagnostic report as I have no control over the B20 at all.

Where from here? It appears that the only solution is to do a brute-force reboot of the B20 – something I am loathe to do. Some prompt advice would be greatly appreciated – I need to get PepVPN going.


#2

Try unplugging all the WANs again and see if the device becomes responsive?


#3

Hi. Good idea, I had tried that – did not seem to have an effect.

When I tried to post the message to the forum the Peplink web site informed me that my message was not accepted, so I was able to find a nice fellow at Peplink tech support to talk with me. (Actually, I was just surprised by your response to a message that I was told could not be posted!) During our conversation the UI briefly reappeared but there was no indication of PepVPN trying to connect – in fact, that entire info box was missing from the UI! CPU remained at 100% the entire time.

As I understand it, the Peplink OS prioritizes tasks (logical) and serving the UI is accorded a really low priority (also logical). Eventually, on the advice of tech support, I did a “brute force” reboot by removing AC power (uuuugh.) I did not like that solution but there was no other solution in sight.

It’s painful to see a Peplink device behave like this one did this morning. :confounded:

Rick


#4

Everything that plugs into a power outlet will eventually fail. 50/50 shot of cycling the power will fix it. Sounds like you were fortunate and it came back to life. Kudos.

Peplink support is pretty awesome. There are lots of folks on the forum willing to help as well.


#5

Yes, and you are one of the folks who are most helpful – TU! :<)

The reason I called Peplink was the forum web site was as unresponsive as the B20. ;<( I was told my message was not accepted. (Later I found out it was! There are “issues” there.)

It’s still unnerving that a brute force reboot was needed to get the B20 to recover. I have greater faith in Peplink than that. Maybe it was the sustained 100% CPU load? Dunno.


#6

How did you achieve Elite Team status?


#7

Who knows? Maybe I’ve handed out a sufficient number of dumb answers? :wink: (Seriously … dunno.)