AT&T USB Modems


#1

I can report that the ATT Beam USB Modem currently shipping in the US works with a peplink balance 20 and ONE with essentially 0 configuration necessary.


#2

Thanks for sharing! :up:


#3

Thanks for the info : I notice the Beam has bad reviews on amazon, but I’m sure most of those folks are not using it with a Peplink. Are you using it as a failover or always on connection?


#4

What firmware are you running on the peplink balance 20? I just picked up a used one on ebay and I can’t get the AT&T Beam to work with it.


#5

Hello,

I would ensure that the B20 is on 6.2.0 firmware (most current). Also, check to see if there any updates for the Beam itself. If you are still experiencing issues I would go into the cellular connection settings on the B20 and change the APN to custom from auto and try putting in a custom APN. Common ones are broadband and i2gold. By logging into the USB modem web interface itself you should be able to see what APN(s) are pre-programmed into it already. Typically APNs are pre-programmed by there region. Being that it was bought from ebay, your region may have a different APN that is needed. If you are still having issues I would create a ticket by emailing support@peplink.com and one of our technical team members will be able to take a closer look into the issue if APN/firmware doesn’t appear to be the cause.


#6

I am unable to update to 6.2.0 as this is out of warranty and on 5.4.x
I have never heard of a router that requires payment for a firmware update.
I understand paying for warranty, but I’m not asking for warranty, I just need a firmware update.
I thought I could use 6.2.1 beta without an unlock code, but that hasn’t worked.
I’m frustrated because I bought this router specifically for the mobile modem and so far that hasn’t worked at all.
It’s actually really shy on other useful features, so this is kinda my last straw.
Is there any way to get this upgraded without spending another $60+ on warranty?


#7

You do not need to pay for any firmware upgrades, please follow the following guide to obtain your unlock key: