AP One / Balance 20 Guest Wifi on Guest VLAN does not work


#1

I have an AP One and Balance 20 (both on latest firmwares) and my second SSID (guest network) does not work.

I have a Data VLAN and Guest VLAN. The data VLAN on wireless works fine. If I join the guest network that is on the guest VLAN, I cannot pull an IP address and can’t even connect with a static address. If I associate the guest SSID with the data VLAN instead of the guest VLAN, it connects just fine.


#2

Hi,

Can you please share us the following setting for us to further check:

  1. What is the firmware version running for B20 & AP One.
  2. May i know the model for the AP one (Enterprise, AC Mini, In-Wall, Rugged, Flex)
  3. The AP is manage by the B20 ?
  4. VLAN settings for B20
  5. SSIDs settings for Guest & Data.
  6. May i know the APs physical connection is direct connect to the B20 ?

Thank You


#3
  1. What is the firmware version running for B20 & AP One.
    B20 - 6.3.3s028 build 3247
    AP One - 3.5.3

  2. May i know the model for the AP one (Enterprise, AC Mini, In-Wall, Rugged, Flex) - AP One Enterprise

  3. The AP is manage by the B20 ? - Yes

  4. VLAN settings for B20 -
    Data VLAN - Untagged - Associated with Data SSID - DHCP Enabled - 10.4.81.0 /24
    Guest VLAN - VLAN 4 - Associated with Guest SSID - DHCP Enabled - 172.16.20.0 /24

  5. SSIDs settings for Guest & Data. - Both SSID’s are broadcasting with WPA / WPA2 personal & I can establish wireless connections with “Limited Connectivity” on the Guest network and I get full connectivity on the Data network. Data network is associated with untagged VLAN and Guest network is associated with Guest VLAN.

  6. May i know the APs physical connection is direct connect to the B20 ? AP One physically connected to port 4, configured as Trunk. I have no “Any” or “Untagged” option but VLAN 4 is checked.


#4

Please ensure the Port Settings as below.


Please refer screenshot below to revert to the port settings above.


Hope this help.


#5

This works, but does it mean I can’t assign VLANs to ports and also have two different wireless networks?


#6

As shown in the picture above you can definitely assign a VLAN to a specific port. For example, if you wanted to assign LAN port 4 to a specific VLAN you have already created, just move your pointer over to the the corresponding VLAN area and click on the small little arrow (drop down) and select the VLAN you want to use for that port. Then click save and remember to apply the changes.

You can certainly define more than one wireless network, the AP One supports up to 16 unique SSID’s.

Thanks.


#7

The problem is I have to REVERT the port settings as shown in the picture above to get it to work, which gives you no configurable VLAN options.
If I leave port type settings enabled, the trunk to the AP One does not work; only the untagged VLAN seems to work with any given SSID regardless of how I configure the trunk.


#8

New firmware 7 should work for you. I had similar issues. With 6.3.3, you could either have a trunk that expected ALL traffic to be tagged. That meant the untagged VLan traffic would be dropped. Version 7 allows you to include the untagged LAN as well as your VLans. You should be able to leave the ports as Access ports to allow all networks in with 6.3.3.

Since I am sure you tried the Access port setting, do you have any other switches/routers between the AP and the Peplink? If there is a managed switch in the path, make sure that the trunk settings are correct for the Interface that the AP plugs into. Also make sure that the uplink to the Peplink is also including the tagged and untagged traffic.

Hope this helps


#9

Sure enough that did the trick. Thanks!!