AP One AX - Cannot choose channel 36 for 5Ghz

I believe there is some kind of bug that prevents my AP from using the 5 Ghz channel 36. I am using the AP controller function and have removed channel 40 from the available channels, yet it chooses channel 40. I try to override it with a “Custom Radio Config” to use channel 36. I see the synchronization is applied, and the channel changes to channel 40 instead of 36. I can set it to channel 149 via the Custom Radio Config and it behaves as expected.

For whatever reason, when left to auto – both of my AP One AX choose channels 6/40. There is something not quite right with the way these things are scanning and selecting channels. I have manually selected the channels to avoid them ending up on the same channels - that is when I found that the AP doesn’t seem to like channel 36 at all.

I would think that channel sharing would be easily avoided when using an AP controller. The APs may not know how to avoid the conflict by scanning (I suspect they all scan at the exact same time and both jump on the clearest channel), but the controller sure knows that they are on the same channels. Why doesn’t the controller force a rescan on one of the APs (forcing a staggered scan)? Since the profile config doesn’t even include the channel the APs were landing on – it seems there were a couple of missed opportunities to resolve the conflict.

I am trying to diagnose some zoom call quality issues and I cannot determine if it is shared wifi channels, or if the issue is further down the line with the ISP (too much congestion). I just now statically assigned channels, so I will see if the issue persists.

May I know what is the model of the AP Controller? WIFI WAN is enabled for the AP Controller?

Have you enabled WIFI Mesh with the AP One AX? If so, where it is connected to?

Balance One Core is the AP Controller and it appears to be functioning correctly with all other aspects of AP management. There is no Wifi Wan for my Balance One Core. There is no mesh enabled on these access points (2X AP One AX). Hopefully you can replicate this in your lab.

I will try to spout out pertinent information to assist with the troubleshooting…

AP Contoller has 2 profiles defined (AP->Settings). One profile is for 3 AP AC One Minis and it includes a mesh on the 2.4 GHz radio. All APs using this profile are able to communicate. All 3 use the same 2.4 Ghz channel. Available channels via the profile are 1, 2, 10, 11 / 40, 48, 153, and 161. Channel scanning is set to 02:00 for 2.4 and 03:00 for 5 Ghz.

The second profile is used by the two AP One AX devices. There is no mesh assigned to this profile. Available channels via the profile are - 4, 5, 6, 7, 8, 9 / 36, 149. 157, and 165. Channel scanning is set to 01:00 for 2.4 GHz and 02:00 for 5 Ghz.

As a workaround, I have created “Custom Radio Configs” (AP->Access Point-> little square and pencil icon). The only setting in these configs are the channel selections. I statically assigned one AP to 9/149 and the other to 4/165. I originally tried to get the first AP to use 36/149 - but when I had 36 configured - it changed to 40.

Let me know if there is any other information that I can provide.

What’s the channel width configured for the radio profiles? It is possible that your devices are falling into the following case as you have devices running on channel 40.

Quote from standard: Scanning requirements for a 20/40 MHz BSS

Before an AP or IDO STA starts a 20/40 MHz BSS, it shall perform a minimum of dot11BSSWidthChannel-TransitionDelayFactor OBSS scans (see 11.14.5) to search for existing BSSs.

If the AP or IDO STA starts a 20/40 MHz BSS in the 5 GHz band and the BSS occupies the same two channels as any existing 20/40 MHz BSSs, then the AP or IDO STA shall ensure that the primary channel of the new BSS is identical to the primary channel of the existing 20/40 MHz BSSs and that the secondary channel of the new 20/40 MHz BSS is identical to the secondary channel of the existing 20/40 MHz BSSs, unless the AP discovers that on these two channels are existing 20/40 MHz BSSs with different primary and secondary channels. If an AP or IDO STA starts a 20/40 MHz BSS in the 5 GHz band, the selected secondary channel should correspond to a channel on which no beacons are detected during the dot11BSSWidthChannelTransition-DelayFactor OBSS scan time performed by the AP or IDO STA, unless there are beacons detected on both the selected primary and secondary channels.

NOTE—The 20/40 MHz channel sets and their corresponding behavior limits (i.e., choice of primary and secondary channels) permissible in each regulatory class are defined in Annex J and Annex I, respectively. An HT AP or an IDO STA that is also an HT STA should not start a 20 MHz BSS in the 5 GHz band on a channel that is the secondary channel of a 20/40 MHz BSS.

The AP or IDO STA may continue to periodically scan after the BSS has been started. Information obtained during such scans is used as described within this subclause and within 11.14.12.

I am using the auto channel width.

I got to be honest, I only understood a couple of words in that standard definition. I have a lot of learning to do…


I imagine there is something that I am just not quite grasping when it comes to channel selection. Please let me know if any of my following assumptions are true or false

  1. Two access points broadcasting on the same channel in close proximity is bad
  2. When an access point sees another radio broadcasting on its own frequency and the frequency is set to auto - it should change it’s channel at some point.
  3. There is no relationship between SSID and broadcast frequency
  4. Channel overlap can cause connectivity issues between APs and wifi clients
  5. The PRO version of the AP controller actively controls channel selection and conflict removal (the basic one seems to be a config pusher and “window” to the AP for management)
  6. AP config hierarchy is as follows (top level trumps lower level for any conflicting settings)
    a. Custom Radio Config (assigned by local AP Controller)
    b. Profile settings (assigned by local AP controller)
    c. local AP settings
  7. There is no way to force a config refresh other than a reboot or changing the config in some way

I have found that one of my AP One AX devices will not honor the channel that I have statically assigned (again). This time, I am trying to force it to 153, but it is stuck on 149 for some reason. I am struggling to understand this because I have made the two “pools” (via Profile) for available channels to be mutually exclusive. One pool is for the AP One AXs, the other pool is for the AP AC One Minis. I had both profiles set to auto everything, but when researching random wifi disconnects and stalled internet traffic situations – I usually find that two APs are broadcasting on the same channel and my client device with the issue is attached to one of them. Maybe I am chasing my tail and this is just a correlation and not a causation relationship. Any help is greatly appreciated. I really want to understand this stuff better.

On 5GHz, each channel is 20MHz in width. For Auto channel width on 5GHz, 80MHz should be used for your case.

With 80MHz, it bonds 36, 40, 44, 48 and 149, 153, 157, 161 (for the channels you have selected). If a device chooses channel 36 with width 80, it is actually using 36, 40, 44, 48 at the same time. So a device with channel 36 and a device with channel 40 would interfere each other with channel width 80.

To avoid interference, you could try to adjust the channels for the 2 profiles, adjust the channel width to avoid channel overlapping or (if applicable) reduce TX power to reduce coverage overlapping.

For the quote, in short, when a device wants to broadcast on channel 36, it will scans the neighbor frequencies. If it finds that there are devices broadcasting on channel 40 as the primary channel and 36 as the secondary (and no other SSIDs broadcasting on channel 36 as the primary), it will use channel 40 as the primary channel.

1 Like

This is very helpful information and describes exactly what I am seeing. When I change everything down to 20Mhz width – everything behaves as I would expect, and all my manual channel assignments are honored across both frequencies.

I have dorked around and think that I have come up with a strategy that covers my entire home in both spectrums without channel overlapping. I think.

My house is 1 story and goes from East to West in a straight line. I have my APs set up from East to West as Mini1–AX1–Mini2–AX2–Mini3.

I have disabled the 5Ghz radios on the minis and the two on the edges (Mini1 and Mini3) have no wired uplink – they connect via a 2.4Ghz mesh to Mini2. Since they are all in a mesh – they all use the same channel. They landed on channel 2 with a 40Mhz width. They are set to auto channel. No AXs are included in the mesh (mixing the hardware didn’t work for me the first time I tried).

The AXs are currently being statically set for both 2.4Ghz and 5Ghz. 2.4Ghz is using the 40Mhz width, and the 5Ghz is using the 80Mhz width. I have AX1 set to 11/165; and AX2 set to 7/36.

This leads me with a channel map something like this
2/- == 11/165 == 2/- == 7/36 == 2/-

I am assuming that since I enabled auto channel scanning for the 2.4Ghz on the Minis – it should either pick channel 1,2,3,4,or 5 – but that is just a guess. As long as it doesn’t land on channel 7 or 11 (also 6,8, 9, or 10 because 40Mhz width), I think it should be fine. If I find that it lands on a channel in use by the AXs – I will statically set it to a non-conflicting channel.

FWIW - I did try to only statically set the channel width and leave the channel assignment as auto across the board – I saw an AP move from a channel that had no conflict on both 2.4 and 5Ghz to conflicting channels for both. There is just something about 7 and 36 that these things really like.

If my static channel and width assignments are in fact appropriate (i.e. they really don’t overlap nor “stomp” on each other) - I am wondering why it didn’t settle on such a configuration when in Auto mode. Other than disabling the 5Ghz radios, it should have been able to sort the 2.4Ghz spectrum a bit better than what it was doing. It seems to me that with an AP controller aggregating all types of information, and APs that are all discovering their neighbors – it could have come up with a way to maximize channel coverage. If not doing it automatically, perhaps a notification about conflicting channels in the AP Controller? Maybe even a basic wizard to walk folks through a couple of potential scenarios to maximize coverage while minimizing overlap? Just throwing out ideas because as it stands, it is not very obvious as to what is happening in the background, and I do believe this to be the source of some connectivity issues.

I do realize that the majority of folks aren’t using 5 access points in their home. I can get by with 3, but I had the other 2 on hand and figured that it couldn’t hurt. My house is not surrounded by rogue wifi signals since I live kind of out in the boonies. My point is that every device is a peplink device and they are all reporting back to a central site (AP controller). If nothing else the AP controller can aggregate channel scan/change logs that indicate some kind of decision tree and the outcomes that lead to it choosing the channel that it did. Just spit-balling some ideas… It looks like the “Nearby Devices” section is a simple aggregator right now, but it is being fed all the data required to generate an “optimized” channel layout.

Not to be completely negative, I do think that the auto-power stuff is working quite well. I could tell that the power was decreased whenever there was a conflict, and then it raised the power back up when the conflict was removed. Also, I was able to eventually use the AP controller and information it gave to resolve the conflicts. The cook-down/hierarchical configuration methodology provided the means to combine like configuration values via the “Profiles”, and granular settings via the “Custom Radio Config” - so, kudos.

Really, my only complaint is that the router didn’t point out that I was an idiot. It had to know… :laughing:

Just as a followup. Having removed all the competition for wifi channels from my wifi environment – everything just works now. I am no longer facing issues where client devices are unable to access the internet/intranet.

Besides clients maintaining a stable connection, I have also noticed the following…

  1. No APs are in my nearby device table - prior to separating channels, I would see every one of my APs in this table. I only see station probes.
  2. I have seen a huge reduction in the association/disassociation entries. Mobile devices still trigger these events - either from power saving or roaming through the house, but the overall amount has decreased significantly.
  3. The mesh is proving to be quite reliable and extends the wifi as expected. Since there is no channel saturation - the power limit can be maximized and thus extends the range.
  4. The nearby device table has decreased from 200 entries to just 40 - and they are all station probes. I assume that when an AP is in this table - it means that it is competing for the radio channel. If auto is selected, it will try to find an open channel; but if it cannot – it will decrease the power to avoid the conflict.

One thing that I don’t fully understand is when an AP is configured to use channel 36, but it finds an AP broadcasting on 40 (primary) and 36 (secondary) - why does it choose to use channel 40? Seems that there is just as much conflict using channel 40 as there is using channel 36?

We followed that standard but the standard didn’t give an explanation to that.

Here’s some notes that might help.

  • One AP broadcasting on channel 36 (primary) w/ 40 (secondary) and another AP broadcasting on channel 40 (primary) w/ 36 (secondary) might have adjacent channel interference
  • HT20 (only) capable STA will send/recv packets on the primary channel
  • STA will mostly stay on the same channel as the AP unless STA triggers an off-channel scanning
  • Some online resources suggest that having APs on the same channel performs better than having APs on different adjacent channels (overlapping)