AP Controller in Balance One not seeing some APs when not used as router/DHCP server

A client of ours recently had us replace a Balance One with another appliance brand as their main router for various reasons. So we just disabled the WAN ports and DHCP services on the Balance One but left it connected to the network to manage the three Pepwave APs they still have. The problem I’m seeing now is that only one of the APs is showing as online in the AP Controller page on the Balance One even though all are on the same LAN, connected via switches. (And the client sometimes reports wireless connectivity problems during busy times, so I’m suspecting the lack of AP visibility to the controller is the culprit.)

I’ve tried power cycling the Balance One a few times and there’s no improvement in the situation.

Why aren’t all of the APs showing as online? The MAC addresses are still the same. Does it matter that the Balance One is no longer the DHCP server? If so, why?

Thanks for your insight, all.


Do you have the AP controller setting configured for the APs ?

1 Like

This won’t work without the Balance acting as DHCP server. The APs will be looking at their gateway as the controller, and the gateway is not the Balance. You have to tell the AP’s where to find Balance One.

Some balance models such as the B380 can control AP’s at external locations outside its own LAN. For that to work the APs need to know how to find the controller. You accomplish that by creating a local DNS record in the router at the remote site. The format is host name “wlancontroller” and the IP address of the controller.

The intent to enter the external IP of the controller so AP’s at remote sites can get instructions. You could do the same thing by creating a DNS record in your non-Peplink router, and pointing it to the LAN address of the Balance One.

The glitch is that the Balance One does not support Remote AP Management through its WAN port. It suspect it would work if the LAN if your Balance One is connected to the local LAN (not the WAN port on the Balance One). The LAN side of the Balance One can’t act as a DHCP client so you’d have to assign it a static address on your LAN.


Thank you. Adding the DNS record worked. (My Peplink is on the LAN with the other devices.)

1 Like