Anyone been able to get a Google Fi data SIM to work?

Hello, I have a dual-sim Max Transit that I’m trying to get working with Google Fi. Things I’ve done:

  1. Upgraded Max Transit to latest firmware (8.1.0)
  2. Activated Google Fi (data-only) SIM via their website, confirmed activation via their phone app, also installed in a phone and confirmed I have data
  3. When inserted, Pepwave Dashboard shows ‘no sim detected’, but when I click on details it shows an IMEI, hex, dec, etc.
  4. I’ve tried with the APN as ‘auto’ and also the h2g2 that Google recommends
  5. I have tried turning off the other slot, I’ve tried setting the carrier to Auto, to T-Mobile, etc. all with a ‘reload SIM’ after each individual config change to see if it had any effect.

Any ideas?

Also just tried all the above w/ the Google FI Voice+Data SIM that I use in my phone and I get the exact same as the above (in case that helps at all).


I too experienced this where Google Fi sim would not work installed in the A slot of 20X CAT4. It worked in B sim slot so I just lived with it.

Will it work in the other sim slot?

My understanding is you can obtain up to 4 data-only sims with Google Fi at no cost. Might as well request another one to rule out the SIM since it doesnt cost anything…

Thanks, I’ve tried it in both slots (both the data and the voice/data SIMS). I do have a couple more coming, but since they both work in the phone I think I have that ruled out alredy.

I’m using it successfully in a Balance Two, in a USB modem. No issues.

@enordy What type of sim adapter did you use? I’m wondering if the pins are not aligning correctly?
I have use the google fi data sims (yellow) in many models, with an adapter and the h2g2 apn and everything else auto and it worked fine for me.