Allow to configure WAN MTU on SOTG


#1

After I setup my new Surf OTG I had to set my two desktops and my laptop to an MTU size of 1472 in order to avoid the dreaded “black hole” connection for various websites. After diagnosing that problem all my “real” computers are working quite well.

However, MTU size cannot be adjusted for my iPad air and my Nook reader. As a result they cannot make reliable web connections, especially to https sites. It sure would be nice if MTU could be adjusted on the SOTG to something compatible for the simple web devices.

Details: Cellular modem mode, AT&T Beam modem.

Thanks,
Ted


#2

If any other customers have experienced this please chime in. We have never received any complaints about accessing any certain websites through our device.

Thanks,
Tim


#3

Tim,

If you search all the forums here for “mtu” you will find users have noted the problem on other pepwave products. If you google “mtu size website loading problems” you will have hours of reading pleasure. :slight_smile:

Thanks,
Ted


#4

Dear All

we have peplink balance 20 in our office and we have 100 mbps internet line but we are getting only 5 mbps line from peplink can you help me in this issue


#5

Hi Ted,

I will move this thread to Feature Request for product team to take consideration.


#6

Hi Guys,

Well, setting the MTU size for the router wasn’t a solution. I tried quite a few settings (1540, 1528, 1440, 1200 …) and nothing helped the connection problem on the iPad.

I was careful to set the MTU value, save it, reboot the SOTG, and then recheck via the admin page that the setting was active.

Using “ping www.google.com -f -l xxxx” I was unable to see any difference from the different settings. I wonder if that feature (MTU size control) is really enabled?

I did try connecting the AT&T Beam cell modem straight to my desktop, and then share out the connection via the ethernet NIC to the SOTG. I set the SOTG to wired ethernet WAN mode of course. After doing this the iPad was able to browse any website, as it should. So the desktop computer is handling the MTU path discovery correctly. I also tried this with my Cisco WIFI router, and it worked correctly as well.

I tried turning off the WIFI section of the SOTG, and using my Cisco WIFI router, but this also failed in the same way. It seems that the issue is the packet handling between the Beam modem and the SOTG.

Any ideas?

Thanks,
TJ


#7

Hi TJ,

We experienced certain USB dongles don’t accept the MTU setting you applied on Surf On the Go. Please try to fix the MTU size on AT&T Beam modem and test again


#8

TK,

I spent quite a bit of time searching for a way to do the MTU adjustment on the AT&T Beam (Netgear 340u). I was not successful. I found a patch that changes the modem to a pass through, but it will not load with the latest firmware version. I found the previous version of firmware, but that doesn’t load either.

I’m stuck here.


#9

Hi TJ,

Please open ticket for us to take a closer look.


#10

All,

Jordan @ Peplink mentioned: “The latest firmware V010028 build1266 for Surf OTG has already supported to customize the MTU for USB modem connection.”

The new release solved the problem. It came out about 2 days after I received the SOTG and upgraded it, naturally. :-/

Interestingly, I didn’t need to do anything to the MTU size setting on the SOTG with the latest release. I returned it to the default (1500).

Thanks,
Ted