AirPrint detection

None of the Apple/iOS devices can detect an AirPrint HP Printer on 3 different Networks.

All use a Peplink Balance which makes me believe that there must be some setting in the Peplink Balance I’m missing which is blocking the detection.

Printers work fine with Windows and have static IPs. Ping fine from iOS devices as well.

What am I missing?

You will likely need to enable bonjour forwarding between the network the printer is on and the client networks that want to access it. IN Network > Network Settings | LAN

From the help text

“Bonjour is Apple’s zero configuration networking (Zeroconf) protocol. Normally, it operates only in the local Layer 2 domain. With Bonjour forwarding, you can redirect the Bonjour protocol from one Layer 3 domain to another so that devices on other domains can also be discovered.”

1 Like

Thank you for your response.

It is grayed out and I cannot enable it as all 255 IPs are on the same single network.

According to the help file it is normally on as I am only attempting to detect printers on the same 255 IPs, which I why I assume it’s something else.

I see, you mean three different Balances running three different networks. In which case no idea - how puzzling.

I would run a network capture on the LAN of the balance and see if there was anything obvious going on on the wire.

1 Like

Correct. 3 different Unassociated Networks with 3 different Peplink Balance on each - and no AirPrint Detection on any of the 3 Networks using the 3 Peplink Balance.

Everything else passes perfectly as it should.

I would note that I am on 8.0.1, but this has not worked on previous versions (6/7) either.

Whats the topology? are all the devices connected directly to the balance or are they connected to a switch which is then plugged into the LAN of the balance?

Airprint using bonjour should just work in Layer 2 flat networks like this, so something is potentially blocking the multicast traffic. Don’t see why the Peplink would be doing that - its not something I’ve ever seen a Peplink device do apart from between subnets (so at layer3).

1 Like

I have a Dell x1052p switch on one of the networks. I do not see anything concerning Bonjour or AirPrint in any firmware setting or in the 400 page manual, so I do not see how that could be an issue.

Perhaps not. But since we think Airprint uses the bonjour zero conf protocol and that protocol is layer 2, and you are only using a single subnet / lan segment, then we are suggesting that something working at layer2 is blocking the traffic.

I can’t think of a single way a Peplink device could be blocking the bonjour traffic at Layer2.

1 Like

Yea … I think I’d focus on the Dell switch. Ain’t much else … :neutral_face:

1 Like

Except Dell Switch is on only 1 of 3 non working Balance Networks.

You are right to question the Peplink of course - but I just can’t picture a scenario where the balance can screw with the bonjour traffic in a scenario where the devices are connected via a switch that is also connected to a Balance. Its layer 2, the balance shouldn’t even see the traffic since the switch would keep it between the connected ports. Very strange.

Go back to first principles. DO a direct cable connect between the printer and a IOS device to check that it can print, then add in networking devices until it can’t again.

1 Like

Just a thought, since the printer is an AirPrint – I assume there is some kind of wireless LAN involved, right? It sounds like wireless and wired devices are sharing the same flat IP space. If you are using Peplink for your wireless, make sure that Layer2 isolation is not enabled. That would definitely block what you are trying to do.

Another thing to check is the Internal Firewall rules.

1 Like

Yes good idea - Later 2 isolation anywhere will cause problems.

Airprint isn’t always wireless. Its a driverless printing capability, the air is a reference to it not being weighed down by large drivers I think.

Internal firewall rules are for LAN (and VPN) traffic that has to pass via the router between networks. In these deployments its flat and on the same network so they should not have an effect.

2 Likes

Just to circle back, after literally years, it appears a solution was found.

Had set the HP printers setup using IPv4 as I was not using IPv6 on the network and saw no reason to introduce a potential issue with IPv6.

On a whim, I enabled IPv6 as well as IPv4 on the HP printer. For whatever reason, the change now allows me to detect the Air Printer on the network, even though there is no IPv6 usage on the lan.

Makes no sense, but without the IPv6 enabled on the HP Printer, no iOS devices detect an Air Printer through a Peplink Network, at least as far as I can tell.

Needless to say, it’s working so I am not going to press my luck to further narrow this down.

3 Likes