Accessing LAN side of Peplink device from LAN side of another Peplink on Speedfusion VPN

Trying to learn this…
I’ve got a MAX_MBX here in the field with me. It’s connected to our office’s Balance 310 via a Speedfusion VPN connection (Static IP on the Balance).
The Balance 310 is the hub for the Speedfusion VPN.
At another location I have a MAX_Transit with a single piece of equipment (video streaming decoder) on it’s LAN. The MAX Transit’s WAN is on a static IP. It’s also on the same Speedfusion VPN.
From my location in the field, I can ping the Balance 310. (via the MAX MBX)
I can also ping the MAX_Transit from here.
But from here I can’t ping the video decoder that’s on the LAN side of the MAX Transit.
I can ping the video decoder using the utility in the Transit (of course) and I can also ping it from the utility in the Balance.

What am I missing? I’d like to be able to see equipment on the LAN side of one end-point device (MAX Transit) from the other end-point device (MAX MBX).

Hi. I’m wondering if you may have “NAT Mode” checked on the PeVPN Profile page.

From where you are ping the LAN IPs of Transit and B310. If you can do that then Speedfusion is working. If you can but can’t ping the encoder check that the encoder has a gateway IP set in its network settings as your video guys tend to like to work on static IPs and local networks.

If you can’t ping something, go to the SpeedFusion status page on each device and check that you can see the other subnets listed there. Screen grab them and post here if you like.

@Rick-DC 's suggestion about NAT is a valid one too and the SpeedFusion Status should expose any NAT profile use.

Thanks, still sorting this out. I can ping a device on the MAX Transit’s LAN side that has a DHCP assigned address from the Transit. But the video decoder, which I put on a static IP address, is still not reachable when I’m on the MAX MBX’s LAN side. Both devices are available from my Balance 310 hub.
I did check the NAT mode on the inControl page where I’d set up the Speedfusion VPN and it’s not selected.
Will keep hammering at it.

Our main office is a B310x with a LAN IP of I a B380 that sits on that LAN for backup. The LAN port of the B380 is on the LAN of the B310x at

Our remote sites are 10.xx.12.000. They are all connected to the B310x by Speed Fusion. When I am at a remote site I can ping devices on the main office LAN, and I can ping devices at any of the remote sites, but I could not get areply from that B380.

My ping from remote site hit the B380, but the B380 did not know how to reply, probably because the B380 is connected via one of its LAN ports, not the WAN. The B380 is not expecting to find the remote subnet on its LAN port. I went into the LAN settings of the B380 and added a static route for the remote subnet, which a destination of the B310x main office device. Everything works with that entry.

Normally Speed Fusion figures these things out automatically but since my B380 was not actually using Speed Fusion itself it did not search for the route on its own. I don’t know if thats the same as your problem. Easy enough to add a static route to your MAX MBX.