Access Cell Modem UI from Network

Balance 20
8.1.0 Firmware

Rural area - two Verizon cell modems - MIFI 8800L (via USB) + T1114 (via Ethernet cable)

  • both Inseego / Novatel products

I am unable to connect to the UI of the modems via the wired network using the IP addys reported by Dashboard in the Peplink router UI. I can connect via WiFi directly.

Both modems seem to be working fine as far as Internet Connectivity goes.

I’ve researched this extensively over time, but no luck. Any pointers will be appreciated.

Hi - welcome to the forum.
WHat is the LAN IP of the Balance 20? I suspect its 192.168.1.1 which is also the default IP for the 8800L and T1114.

Only way I can think of is to change you LAN IP to something else, then set an enforced outbound policy rule for 192.168.1.1 which you then point at the correct WAN to access the device you want to manage.

Thanks for the reply.

I’ve run the Balance 20 with a different LAN IP address range for a couple of years - still can’t connect.

Dashboard and the WAN config on the B20 show the modems with an IP within the first 9 numbers of the IP address range - DHCP assignments starting at 10. Neither is set at 1 which is the B20 IP. For example, now it’s showing the 8800L as 192.168.1.5.

But you might be on to something with the default addresses - might explain the browser / network behavior when trying to resolve the address. I will try to access the modems directly and change is default IP.

But still puzzled as to why the B20 is reporting incorrect addresses for the modems.

If both WANs have modems using the same range (192.168.1.0/24) there will be routing confusion. Try disabling a WAN and see if you can access the other modem.

What do you mean? Where?

I would think that if both WAN modems used the same address, there would be routing confusion. As long as the IP addresses are unique (even within the same range), there shouldn’t be a problem.

I’ve only been using the 8800L until I get this squared away. On the Dashboard tab of the B20 UI, it reports the IP address of the modem - right now 192.168.1.5, which is unreachable.

I’m assuming that address is given to the 8800L by the B20 DHCP server.

Can the 8800L accept an address from the B20 router? I haven’t been able to find anything concrete about that. It has a DHCP server, but can it be a DHCP client?

Not the case. If I have the same subnet on both wans and I need the balance to route to an IP that can be in either subnet on either WAN how would the balance know which WAN to use? It doesn’t unless you use outbound policy to specifically tell it.

On the dashboard of the balance you’ll see the IP address assigned to the WAN interfaces of the balance. If you click the ‘details’ link you’ll see the default gateway. Typically the default gateway is the next hop router / modem - the 8800L in your case. In my example below the default gateway is a P2P wireless link that is giving my WAN 2 an IP of 10.22.1.152 via DHCP. The router is actually on 10.22.1.254.

Not on the WAN no.

It is very unlikely that the 8800L can be a DHCP client.

1 Like

MartinLangmaid: Thanks for your attempt to help me, but I’m finding your posts confusing and not on point. On the subject of networking, we are in different places conceptually and I see no hope in communicating successfully.

I’m hoping someone else can chime in here to help me clarify my understanding of the problem.

A first for me, I must be confused as to what your problem is.

Let me help get you some more eyes on this.
@Rick-DC @C_Metz any chance you can assist?

1 Like

Hi @MartinLangmaid. Actually, I think I have been confused on this one from the beginning and not sure any answers I’d provide would be different than yours. :face_with_monocle: But …

@kapellmeister456 … So, the subnets (not addresses) shown by the B20 are the same – or different – for WAN1, WAN2 an LAN?

1 Like

192.168.1.5 is not the address of the modem, this is the address the modem has assigned to the Balance 20. The address of the modem would be 192.168.1.1 (unless you have changed it to something else).

If your Balance 20 is also using the default IP address of 192.168.1.1 then this is a problem. At a minimum you should change the default IP of the Balance to something else, for example 192.168.2.1.

Hope this helps.

1 Like

Thanks, this is helpful

The B20 UI Dashboard seems to be telling me that an IP address has been given to the modem - not the other way around.

I understand that two devices cannot have the same IP address.

I can access the modem UI directly, using the modem’s WiFi. Can I access the modem UI from the LAN? How are devices connected to the WAN ports (USB / ethernet) handled by the B20, LAN access wise?

Typically if you want to access the upstream modem from the LAN, you simply write enforced rules in your policy. I have 2 upstream WAN modems that I access from my LAN. A Mofi4500 using 192.168.10.1 and a T-Mobile router using 192.168.100.1 Both can be managed from any LAN device on the network. These rules screenshot below allow me to manage the devices even when they are marked as down by health checks. The T-Mobile devices default LAN was 192.168.1.1 and I had to connect via WiFi and change it to 192.168.100.1 for this to work.

1 Like

Our suggestion is that you do not overlap any network assignments. It causes all sorts of subtle interactions. Will it mostly work?.. Yes… will it fail in interesting ways… Yes.

when you say it has worked for years… Sometimes you get lucky. I’ve seen badly configured networks work for years until something changes, and poof, the odd design fails as it was never to spec to begin with.

So we would connect a computer directly to the MIFI 8800L and configure the MIFI router to manage 192.168.2.X and take the T1114 and configure it as 192.168.3.X. Then reconnect the devices to the balance.
This makes it clear which management interface you are hitting and that the balance knows exactly how to get there.

As was pointed out the IP address (192.168.1.5 in this case) is not the IP of the router, but the IP of the wan interface of the Balance20. Clicking on the details should give a default router, and that is the management interface for the modem/router.

We are assuming that the MIFI can be configured via its USB port. I see no reason to believe that this isn’t true, but it should also be tested. If the MIFI is connected directly to a PC, via USB, can you manage it?

Finally, some clarity (on my part)!

Many thanks to AskTim, Rick-DC, C_Metz and Paul_Mossip

Apologies and many thanks to MartinLangmaid. I think you nailed it with your first answer, but there were too many misconceptions on my part to appreciate it.

@Paul_Mossip - yes, one can manage the 8800L MiFi via USB.

I get less info from the Details on the WAN USB connection than the ethernet connection.

1 Like

To build on the response from @MartinLangmaid and others:

Assumption:

  • Your Balance 20 (“B20”) WAN 1 is connected to a Verizon modem (“modem”) (or some other modem device, it does not really matter much which or what).
  • The modem assigns IP addresses to its clients, and specifically to the B20.

Procedure to test:
Let’s forget terminology for now, and simply do the following steps and see if that works for you. (I grabbed a local B20 for illustration purposes. It is running 8.0.1, but for these purposes the difference should not matter)

  1. Open the B20 UI, and look at the dashboard. With one WAN connected it should look something like this:


Note the circled IP address. This is the address of the B20 WAN 1 interface assigned to it by the modem. Note in particular the third element in the quad (“0”).

  1. Click on the “Details” link to the right of the IP address. You should get something like this:

Make a note of the Default Gateway address (192.168.0.1), this is the address of the modem as seen from the router (“modem address”). You’ll need that later.

  1. Open Network > LAN Network Settings.

For the untagged LAN (or the VLAN your PC will connect to) open the LAN settings:

Set the IP address (and the DHCP IP ranges to a different IP segment from the one assigned on the WAN 1. In this example, set the third quad number to anything different from “0”.

Save.

  1. [Optional - of use under some circumstances] Open Network > Outbound Policy and create a new rule:

For Destination use the modem address noted in 2.

Save.

It should now look like this:

That should do it. Access from a LAN connected device (your PC) to https://192.168.0.1 (or whatever the modem address is) should drop you into the LAN-facing UI of the modem.

Coda:

With your two modems make very sure your to WAN connections are on different address segments. E.g., if both your modems assign addresses in the 192.16.8.0.xxx range, and both WANs report the same gateway addres (e.g., 192.16.8.0.1 in our example) then you have to change the DHCP range of at least one of them. E.g. as in this example from a B380 with three ISPs/modems: Note that the third number in the IP quad as assigned to the router by each modem is distinct from the others.

Good luck,

Z