Ability to change session timeout via GUI


#1

I have a support case open with a couple of 380s in HA cluster using drop in mode. We had an issue recently where about every 21 hours we would exceed the max sessions and have to reboot the unit. Support adjusted the timeout from 24 hours to 1 hour and things have stabilized, but if I reboot, the session timeout reverts to 24 hours and we are back to the same issue again. The corporate firewall session timeout is 15 minutes so it doesn’t make sense that the peplinks would need to stay at 24 hours.

I’d like a way to set this value permanently, either from the GUI, or from console/ssh. I have two units that I need to move to new PDUs and can’t because of this issue.


#3

@Beavis, do you mind to share ticket number and enable Remote Assistance for us to investigate the units? As we have improved our device session handling in firmware 7.1.0GA onwards, so we would like to check on devices condition.

The request for a configurable “Session Timeout” value has been sent to the Engineering Team to be reviewed and considered.


#4

I am using a partner(Frontier) for support who has all of the ticket information. I was not given this information.

Remote support has been enabled for the past few weeks as we have updated firmware a few times and finally come down to the session limit issue and timeout change. I believe there was some other sort of bug that they cleared out as well because the session times were showing -20:-14:-45 and would not clear out at all. That has since gone away with whatever support has done to change the session timeouts and clear out those stale sessions for us originally.


#5

+1 Configurable Session Timeout values would be very useful.


#6

We will support an option to allow user reduce the number of maximum session in next firmware.


#7

We expect your case should work without reduce the number of session, will follow up with you in support ticket in details.


#8

I am not really looking to reduce the number of sessions, the problem we actually had was to many sessions causing the master to stop responding, bringing down the connections but not allowing the slave unit to failover. Myabe I misunderstood your reply but it sounds like you are saying there will be an option to reduce the maximum number of sessions, not the session timeout.


#9

Sorry for my mistake, I want to clarify here.

We will support an option allow user to configure the session timeout.


#10

Any updates on adding this feature?


#11

@Beavis

The feature is in the feature list now but no details road map yet. We will post again if get any update from Engineering team.