6.1.2 firewall does NOT work


#1

hello,
i upgraded from firmware version 6.1.0 build 2863 with firewall rules working as designed. then i upgraded to firmware 6.1.2 build 3071 and none of my firewall rules worked. I even deleted them all and re-created with still no luck. I even removed every firewall rule and created one simple firewall deny rule. it did NOT deny the traffic. My only option was to revert back to 6.1.0 at this time.


#2

No one else has reported any issues with the firewall in firmware 6.1.2. What device are you using?


#3

A support ticket has been opened to look into this.


#4

I have found this issue to be on true on balance 380 and 1350. It is specific to firewalling traffic across a speedfusion tunnel, not out to the internet.


#5

Hi,

Thank you for your valuable input. We are looking into this problem now.


#6

PepLink has come back acknowledging this issue. Everyone who is running firmware version 6.1.2 utilizing firewall rules over SpeedFusion tunnels you better ensure they really are working for you. Here is the response I received from support. This could have been detrimental to my organization due to the sensitive industrial controls network we operate with these appliances. I hope PepLink does a better job of QA moving forward in the future. Due to the firewall issue on this release it also affected my VoIP traffic over SpeedFusion. I suddnely started getting “ring no answer” symptoms. Back Reeving the firmware resolved this issue also.

“Engineering is aware of this situation and they are working on a fix for new firmware versions. Thank you for your patience.”


#7

We acknowledge the issue and scrambled to put together a fix release as soon as we can. Our thanks go to “apudlak” and other customers who reported this bug to us immediately.

Thank you for your patience.

Keith


#8

Wildcards don’t work either in 6.1.2 but looks like it is fixed in the 6.2 beta so hope the final 6.2 is out soon…

If you try to enter facebook.* to deny it says something like “invalid domain”.


#9

Hi,

Our engineering team is working hard on this. Thank you for your patient.


#10

Even with the 6.2 beta, if you try to block facebook.* on a Balance 30 or Max 700 it doesn’t work (and has never worked), why is that? Do they not have enough processor power and if so you shouldn’t offer the feature on them…


#11

As stated above, this is a bug that they are working on fixing…Update will be provided once a fix is available.


#12

Hi Andrew,

Appreciate if you can upgrade to this firmware in order to fix the firewall issue - http://download.peplink.com/firmware/plb700/fw-b380_390_580_700_710_1350-6.1.3s3-build3148.bin.

Thank you.