wanDNS that never inserts a non FQDN (dot as value) in SOA MNAME


#1

Preface: In SMB scenario’s on a low budget where the same server hardware hosts both the http and the authorative DNS server, one would like to configure a single hostname. To speed up global name resolving using as less different hostnames as possible and insert glue records as early as possible, the slave NS records are configured at the most requested records, like www.domain.tld and/or mail.domain.tld and/or domain.tld.

The PepLink Balance is used as comfy interface for maintaining DNS records but is connected to relative slow ADSL WAN links with high latency. Therefore the Balance is used as invisible authorative DNS master server. Balance allows zone transfers to slaves. Where each slave has high bandwidth, and low latency internet links. Therefore the Balance itself is not used as NS record.

The result of such a setup in combination with long TTL’s, is a DNS lookup speed <just-dnslookup.com> that outperforms most DNS hosting services and comes close to top performing and ditto expensive anycast DNS hosting services like ultradns or akamai, having global resolve times (in all 50 measurement points) usually below 500 milliseconds (green): 136ms on average for this self hosted setup versus 61ms for ultradns versus 207ms for akadns. And this for a setup where master and slave server are not even on different continents but located on a 200 kilometers distance between each other.


In such a situation a nameserver (NS) record is configured on the domain name ‘.’ (dot). This due to that the Balance does allow configuring an NS record with an empty value, and shows domain.tld (cursive and in gray font) in the user interface on save. After ‘Applying changes’ the empty NS records is stillshown </cgi-bin/MANGA/index.cgi?mode=config&hidx=3&option=wandnsdomain&domainID=…> before the changes have been applied. But the empty NS record is often lost on subsequent opening of </cgi-bin/MANGA/index.cgi?mode=config&hidx=3&option=wandnsdomain&domainID=…> after settings ‘have been applied’ or published as a duplicate of the other (non empty) NS record:


;; ANSWER SECTION:

domain.tld. 1209600 IN NS www.domain.tld.

domain.tld. 1209600 IN NS www.domain.tld.


Another option is to enter the NS record as ‘domain.tld.’, loosing the ability to enter a glue IP address.

So choosing for entering a dot (.) in the NS record field


;; AUTHORITY SECTION:

domain.tld. 1209600 IN NS domain.tld.

domain.tld. 1209600 IN NS www.domain.tld.


This incorrectly inserts the valid NS dot into the SOA MNAME field.


;; ANSWER SECTION:

domain.tld. 1209600 IN SOA . hostmaster.domain.tld. 1304114386 14400 3600 2419200 300


In the SOA MNAME only fully qualified domains are allowed and dot becomes invalid. The dot (.) in SOA MNAME should be replaced by domain.tld